NetBackup™ クラウドオブジェクトストア管理者ガイド
- 概要
- クラウドオブジェクトストア資産の管理
- クラウドオブジェクトストア資産の保護
- クラウドオブジェクトストア資産のリカバリ
- トラブルシューティング
クラウドオブジェクトストアアカウントでエラーが発生した
説明
Web UI で、クラウドオブジェクトストアアカウントの状態は次のように表示されます。
クラウドオブジェクトストアアカウントでエラーが発生しました。ユーザーマニュアルを参照してアカウントを再作成してください。
この状態では、クラウドオブジェクトストアアカウントを編集できません。クラウドオブジェクトストアアカウントに対応するすべてのジョブが失敗し続けます。
原因
クラウドオブジェクトストアアカウントは、次の場合にエラー状態になります。
csconfig CLI を使用して、クラウドオブジェクトストアアカウントに対応するエイリアスが誤って削除された。
csconfig CLI を使用して、クラウドオブジェクトストアアカウントに対応するエイリアスが誤って更新された。
メモ:
クラウドオブジェクトストアアカウントに対応するエイリアスの更新には、csconfig CLI を使用しないことをお勧めします。同じように更新する正しい方法は、編集ワークフローまたは create-or-update API を使用することです。クラウドオブジェクトストアアカウントと同じ名前のエイリアスが、クラウドオブジェクトストアアカウントに対応するエイリアスです。
回避方法
NetBackup ドメイン名は、クラウドオブジェクトストアアカウント、クラウドストレージサーバー、MSDP-C LSU 間で一意である必要があります。これらでは、単一の名前空間が共有されます。そのため、想定される使用状況のシナリオは次のとおりです。
Case 1: クラウドオブジェクトストアアカウントと同じ名前の有効なクラウドストレージサーバーまたは MSDP-C LSU が環境内に存在しない場合。
環境に応じてクラウドオブジェクトストアアカウントの詳細を収集し、取得した詳細をクロスチェックします。
必要に応じて、クラウドオブジェクトストアアカウントに対応するエイリアスが存在する場合は、csconfig CLI を使用してエイリアスの詳細を書き留めます。
次のコマンドを使用して、このタイプのすべてのインスタンスを一覧表示し、クラウドオブジェクトストアアカウントとそのインスタンスを特定します。
<install-path>/csconfig cldinstance -i -pt <provider_type>
次のコマンドを使用して、インスタンスとクラウドオブジェクトストアアカウントの詳細を取得します。
<install-path>/csconfig cldinstance -i -in <instance name>
収集した情報で詳細を検証します。
次のコマンドを使用してエイリアスを削除します。
<install-path>/cscpnfig cldinstance -at <api_type> -rs -in <instance_name> -sts <cloud_object_store_account_name>
エラー状態のクラウドオブジェクトストアアカウントを削除します。
書き留めた詳細を使用して、クラウドオブジェクトストアアカウントを作成します。
Case 2: クラウドオブジェクトストアアカウントと同じ名前で使用中の有効なクラウドストレージサーバーまたは MSDP-C LSU が環境内に存在する場合。
同じ名前は再利用できません。
環境に応じてクラウドオブジェクトストアアカウントの詳細を収集する必要があります。
クラウドオブジェクトストアアカウントの新しい名前を決めます。
エラー状態のクラウドオブジェクトストアアカウントを削除します。ポリシーからアカウントを削除します。
新しい名前と収集した詳細を使用して、クラウドオブジェクトストアアカウントを作成します。古いアカウントが使用していたのと同じポリシーに、このアカウントを割り当てます。
これにより、次回のバックアップ以降、バケットに使用されるクライアント名が変更されます。
NetBackup は古いアカウント名を使用して、古いバックアップを識別します。