問題
C:\ ドライブまたはその他のドライブが System Recovery コンソールに表示されない。
図1
エラーメッセージ
このとき、PartInfo.txt ファイルに、次のような警告が表示されることがあります。
WARNING: Partition above extends beyond end of disk
WARNING: Partition above overlaps with primary partition
WARNING: Invalid Begin CHS values in partition above.
WARNING: Begin CHS does not match start sector LBA in partition above.
WARNING: Invalid End CHS values in partition above.
WARNING: End CHS does not match calculated end LBA in partition above.
WARNING: Logical partition above begins outside of extended partition.
WARNING: Logical partition above ends outside of extended partition
WARNING: GPT Header Check Sum is invalid.
WARNING: GPT Partition Array Check Sum is invalid.
注: 上記は、PartInfo.txt ファイルに表示されるパーティションテーブルに関するエラーの一例です。 その他にも、System Recovery からドライブが見えない "WARNING " メッセージが記録される場合があります。
原因
パーティションテーブルのエントリが正しくない原因としては、次のようなものがあります。ただし、これら以外のも原因がある場合もあります。
1. RAID 構成で先頭の CHS (Cylinder Head Sector) が開始セクタ LBA (Logical Block Addressing) と一致しません。
2. パーティションサイズがディスクの終段を超えています。
System Recovery はセクタベースのバックアップユーティリティであり、完全で正確なパーティション情報を必要とします。この情報を元にすることで信頼性の高い正確なバックアップが保証されます。いずれかのパーティションでエラーが検出された場合、そのボリュームはバックアップが実行できないため、ユーザーインターフェイスには、そのボリュームを表示しません。これは不正確なボリュームを復元すると、データの損失や破損につながる可能性があるためです。この振る舞いはデータを保護するための設計通りの動作です。
解決策
ボリュームがグラフィカルユーザーインターフェース (GUI) にバックアップするドライブとして表示されない場合は、まず次の場所にある PartInfo.exe をダブルクリックします。これにより、同じ場所に partinfo.txt ファイルが作成されます。このファイルを開き、上記のようなエラーの記録を見つけます。
デフォルトインストールパス
C:\Program Files\veritas\veritas System Recovery\Utility
ドライブの表示問題を解決するには、以下の操作を行います。
1) コンピュータを再起動し、システム BIOS に入ります。ドライブの設定が正しいことを確認します。ドライブを正しく検出できることを確認します。必要に応じて、BIOS から必要なドライブを再検出します。設定などの詳細については、コンピュータのシステムまたはマザーボードの製造元に確認します。
2) NAS または SAN デバイスにパーティションが存在する場合は、すべてのコントローラーが最新のファームウェアとドライバを使用していることを確認します。
3) サーバーをシャットダウンし、デバイスを再初期化します。
4) お使いのコンピュータが Microsoft Windows Vista、Windows 7、Windows 2008 以降を実行している場合は、Windows ディスク管理コンソールを開きます。
5) Veritas System Recovery と SymTrackService サービスを停止します。
6) ボリュームに右クリックし、[ボリュームを縮小]を選択します。
図2
7) ボリュームサイズ (MB 単位) を小さくします。
例:ボリュームを 5GB ( 5000Mb ) 入力し、[縮小] クリックします。
これにより、パーティションテーブルの境界が正常な状態に復旧できる可能性があります。この手順の後に再起動が必要になる場合があります。再起動後、System Recovery コンソールからドライブの表示を確認します。
8) Veritas System Recovery 、SymTrackServiceサービスを開始します。
9) System Recovery コンソールを開き、ドライブが表示されることを確認し、バックアップ ジョブを作成します。(注: バックアップジョブの作成時に、ウィザードは、システムの完全な復元に必要な他の隠しボリュームを含めるようにプロンプトを表示することがあります。隠しボリュームと保護されたボリュームはディスクの管理では縮小できません)
10) ドライブがまだ表示されない場合は、PartInfo.txt ファイルを再実行します。それでも警告が表示される場合は、PartInfo.txt ファイルに警告が表示されなくなるまで、Windows ディスクの管理で [ボリュームの縮小] (1Gb - 5Gb をさらに縮小してみる) オプションを使用します。
11) System Recovery によるバックアップデータが存在する場合は、SRD ブートディスクから起動します。
12) エラーが発生している既存のボリュームを削除し、SRD から復元します。
13) それでもドライブが検出されない場合、唯一の解決策は、Backup Exec でファイルベースのバックアップを行うことです。データがバックアップされたら、パーティションを削除してから再構築(リストア)を行うことで、問題が修正できる可能性があります。
14) 再構築(リストア) 対象のパーティションにシステムドライブが含まれている場合は、オペレーティングシステムの再インストールが必要です。
15) サードパーティのユーティリティを使用しても、縮小操作を実行できます。
注意:パーティションエラーは、パーティションが正しく作成または変更されていない場合、またはサードパーティのユーティリティがパーティションに影響を与えた際に発生します。Windows ディスクの管理は、MBR または GPT としてパーティション分割されたディスクを必ずしも区別しません。どちらのディスクタイプも、多くの場合、[べーシック] として表示されます。Windows はパーティションエラーが存在していても、OS の動作に影響が現れない場合があります。