Problem
C:\ drive or another drive does not appear in the System Recovery console.
Error Message
The file PartInfo.txt may have the following warning(s):
- WARNING: Partition above extends beyond end of disk
- WARNING: Partition above overlaps with primary partition
- WARNING: Invalid Begin CHS values in partition above.
- WARNING: Begin CHS does not match start sector LBA in partition above.
- WARNING: Invalid End CHS values in partition above.
- WARNING: End CHS does not match calculated end LBA in partition above.
- WARNING: Logical partition above begins outside of extended partition.
- WARNING: Logical partition above ends outside of extended partition
- WARNING: GPT Header Check Sum is invalid.
- WARNING: GPT Partition Array Check Sum is invalid.
Note: The preceding are just examples of partiton table errors that may be seen in the PartInfo.txt. Other "WARNING" messages may also exist which prevent the drives from being seen by SSR.
Cause
The cause of the incorrect partition table entries can include, but are not limited to:
1. Under RAID configuration begin CHS does not match start sector LBA
2. Partition size extends beyond the end of disk
Veritas System Recovery is sector-based backup utility that relies on completely accurate partition information. This ensures a reliable, accurate backup. If errors are detected on any partition, that volume will not display that volume in the interface as it is not viable for backup. Restoring an inaccurate volume could result in data loss or corruption. This works as designed to protect your data.
Solution
If a volume does not appear in the graphical user interface (GUI) as drive to back up, first double-click on PartInfo.exe in the following location. This will create a partinfo.txt file in the same location. Open up this file and locate the error(s) above:
For 32-bit systems:
C:\Program Files\veritas\Veritas System Recovery\Utility
For 64-bit systems:
C:\Program Files(x86)\veritas\veritas System Recovery\Utility
To resolve the drive visibility issue, do the following:
2)If any partitions exist on a NAS or SAN device, ensure that all controllers are using the latest firmwares, and drivers.
3)Shutdown the server, and reinitialize the device(s).
4)If your computer is running Microsoft Windows Vista, or Windows 7, or Windows 2008, or later, open the Windows Disk Management console.
5)Right-mouse click and choose Shrink Volume...
5) Stop the Veritas System Recovery and SymTrackService services.
6)Reduce the volume size (in MB). This will possibly bring the partition table boundary back into compliance. A reboot may be required after this step. After rebooting try to recreate the backups. Check the drive(s) visibility .
7) Shrink the volume by 5Gb (5000Mb), and click Shrink:
8)Start the Veritas S ystem Recovery service, then the SymTrackService service.
9)Open the Veritas System Recovery console to see if the drive is enumerated. If so, create the backup job. (Note: during the backup job creation, the wizard will prompt you to include other hidden volumes that are necessary for complete system restoration. Hidden and protected volumes cannot be shrunk through Disk Management)
10)If the drives are still not visible, rerun the PartInfo.txt file. If the warnings still appear, use the Shrink Volume... (try shrinking another 1Gb - 5Gb.) option under Windows Disk Management, until the warning is not seen in the PartInfo.txt file.
11)If a backup exists, boot from the SRD.
12)Delete the existing volume(s) that are with errors, and restore them from within the SRD.
13)If drives are still not detected, the only solution is to backup the data using a file-based backup using the Backup feature of Microsoft Windows or Backup Exec for Windows Servers (BEWS). Once your data is backed up, the partition should be deleted, and then rebuilt.
14)If the partition (that needs to be rebuilt) contains a system drive, a reinstall of the operating system will be required.
Note:
Partition errors occur when partitions are created or changed incorrectly, or when 3rd party utilities affect partitions. Windows Disk Manager doesn't necessarily distinguish between disks partitioned as MBR or GPT; Both disk types are often listed as "Basic". Thus, Windows continues to work even if partition errors exist.