問題
ワークグループ環境で、Remote Agent for Windows がインストールされているリモートサーバーのセキュリティイベントログにイベント ID 4625 [アカウントがログオンに失敗しました] が記録されます。
このエラーは、4 時間ごと、バックアップジョブ開始時、クレデンシャルテスト実施時に記録されます。
エラーメッセージ
リモートサーバーのセキュリティイベントログに次のエラーが記録されます。
失敗の監査 Microsoft Windows security auditing. ID:4625
アカウントがログオンに失敗しました。
ログオン タイプ: 3
ログオンを失敗したアカウント:
セキュリティ ID: NULL SID
アカウント名: サービスログオンアカウントユーザー名
アカウント ドメイン: Backup Exec サーバー名
エラー情報:
失敗の原因: ユーザー名を認識できないか、またはパスワードが間違っています。
状態: 0xC000006D
サブ ステータス: 0xC000006A
Backup Exec の SGMon ログには以下のエラーが記録されます。
MANAGEMENT: [12/23/22 16:53:17] [0000] TASK: Creating task 'ProcessNrdsAdvertising_Asynch' at '[] '
MANAGEMENT: [12/23/22 16:53:17] [0026] 12/23 16:53:17.769[Job ] ProcessNrdsAdvertising_Asynch starts
MANAGEMENT: [12/23/22 16:53:17] [0026] 12/23 16:53:17.769[Job ] ProcessNrdsAdvertising starts: NrdsAgentName=remote1 NrdsAgentKey=2
MANAGEMENT: [12/23/22 16:53:17] [0026] 12/23 16:53:17.769[Job ] GetAgentVersion starts
MANAGEMENT: [12/23/22 16:53:17] [0026] 12/23 16:53:17.769[Job ] GetAgentVersion: before call ValidateRemoteAgent DLL for GetAgentVersionr \\remote1 rc.Flags=NEW_FROM_ADDSERVER, IS_ARCHIVABLE, BACKUP_THROUGH_VIRTUAL_MACHINE_HOST
MANAGEMENT: [12/23/22 16:53:17] [0000] 06:()->Creating destination connection: remote1, remote1\administrator
MANAGEMENT: [12/23/22 16:53:17] [0000] 06:()->Connecting to remote WMI service: remote1, remote1\administrator
MANAGEMENT: [12/23/22 16:53:17] [0000] 06:()->Connecting: root\cimv2, remote1, remote1\administrator
MANAGEMENT: [12/23/22 16:53:18] [0000] 06:()->Starting service: RemoteRegistry
MANAGEMENT: [12/23/22 16:53:18] [0000] 06:()->StartService: RemoteRegistry, Return:0
MANAGEMENT: [12/23/22 16:53:20] [0000] 06:()->Connecting to remote registry: remote1, remote1\administrator
MANAGEMENT: [12/23/22 16:53:20] [0000] 06:()->Connecting: root\default, remote1, remote1\administrator
MANAGEMENT: [12/23/22 16:53:23] [0000] BackupExecManagementService.exe Error: 0 :
MANAGEMENT: [12/23/22 16:53:23] [0000] 許可されていない操作を実行しようとしました。
原因
Remote Agent for Windows はデフォルト設定で 4 時間ごとに Backup Exec サーバーに対して環境情報を通知します(アドバタイズ)。アドバタイズ処理の際に WMI を使用して Backup Exec サーバーからリモートエージェントのバージョンチェックを合わせて実行します。WMI を使用したエージェントのバージョンチェックは Backup Exec サービスアカウント (BESA) で実行されるため、ワークグループ環境ではリモートサーバーに接続できずエラーが発生します。
解決策
回避策:
A) Backup Exec サーバーとリモートサーバーをドメインに参加し、Backup Exec サービスアカウント (BESA) をドメイン管理者にします。これによりアカウントを一元管理できます。
B) リモートサーバーに BESA と同じユーザー名とパスワードのアカウントを作成します。
C) リモートエージェントのバージョンチェックを無効にします。
リモートエージェントのバージョンチェックの無効化は次の手順で実施します。
1.Backup Exec サーバーでレジストリエディタを開いて次の場所に移動します。
HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\Backup Exec For Windows\Backup Exec\Server
2.新しい DWORD 値を作成します。
DWORD 値: SkipAgentVersionCheck
値のデータ: 1
3.レジストリエディタを閉じます。
警告 : Windows のレジストリエディタを不適切に使用すると、オペレーティングシステムが正常に機能しなくなる可能性があります。 Windows レジストリを変更する際は十分に注意してください。レジストリエディタのアプリケーションを使用した経験がある場合にのみ、レジストリの修正を行ってください。また、レジストリに変更を加える前にレジストリとコンピュータのすべてのデータをバックアップすることをお勧めします。