Problem
Deleting cloud deduplication storage devices requires several manual steps. Manual intervention helps protect the device from ransomware, malicious or accidental removal.
Error Message
Unable to delete cloud deduplication storage device.
Cause
Backup Exec Ransomware Resilience protects storage devices from non-authorized access or removal.
Solution
Deleting Cloud Deduplication Storage
- Disable the Disk storage lockdown setting:
Configuration and Settings > Backup Exec setting > Network and Security > Disk storage lockdown
Open command prompt. Change path to BE Install location.
By default install path is on C drive so type cd C:\Program Files\Veritas\Backup Exec and hit enter.
Run this command -> pddecfg -a listcloudlsu
A list of cloud deduplication storage devices is displayed, note StorageID and CachePath
- From the Backup Exec console, right-click the cloud deduplication storage, and click Disable
- Right-click the cloud deduplication storage and click Delete
Cloud Deduplication storage information is deleted from ‘cloudlsu.cfg’ file
- Stop deduplication services
- Backup Exec Open Cloud Storage Daemon (ocsd)
- Backup Exec Deduplication Engine (spoold)
- Backup Exec Deduplication Manager (spad)
- Delete the storage container or bucket configurations in spoold using the command:
spoold --removepartition <storageId>
Cloud Deduplication storage information is deleted from ‘cloud.json’ file
- Remove the cache folder using Windows Explorer or by using the command:
rmdir /S <CachePath>
- (Optional) Remove the sub-bucket folder from the cloud
- Start the deduplication service and the monitor service
- Enable the Disk storage lockdown setting:
Configuration and Settings > Backup Exec setting > Network and Security > Disk storage lockdown
Deleting A Bucket/Sub-Bucket
- Open command prompt. Change path to BE Install location.
By default install path is on C drive so type cd C:\Program Files\Veritas\Backup Exec and hit enter.
Run this command - pddecfg -a listcloudlsu
A list of cloud deduplication storage devices is displayed, note StorageID and CachePath for bucket/sub-bucket to delete
- Stop Deduplication Services from Service Manager and restart BE services
- Disable the Disk storage lockdown setting:
Configuration and Settings > Backup Exec setting > Network and Security > Disk storage lockdown
- Delete the storage container or bucket configurations in spoold using the command:
spoold --removepartition <StorageID>
- Remove the cache folder using Windows Explorer or by using the command:
rmdir /S <CachePath>
- Start Duplication services and Restart Backup Exec Services
- From the Backup Exec console, right-click the cloud deduplication storage, and click Disable
- Right-click the cloud deduplication storage and click Delete
- Enable the Disk storage lockdown setting:
Configuration and Settings > Backup Exec setting > Network and Security > Disk storage lockdown