During a Compliance Accelerator (CA) or Discovery Accelerator (DA) export, an Event ID 236 'Error moving MSG to PST' is generated.
Problem
During a Compliance Accelerator (CA) or Discovery Accelerator (DA) export, an Event ID 236 Error moving MSG to PST
is generated.
Error Message
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 234
Description:
APP AT - Customer ID: 2 - !!An error occurs during cleaning the PST object.
V-437-234
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 235
Description:
APP AT - Customer ID: 2 - An error occurred when requesting the PST COM object. System.Runtime.InteropServices.COMException (0x8004010F): Exception from HRESULT: 0x8004010F
at KVS.EnterpriseVault.Interop.PSTProviderClass.OpenPSTEx(String PSTFileName, String PSTPassword, enumOpenMode ePSTOpenMode, Int32 Unicode, UInt32 MaxSizeMb)
at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.get_ThePSTProvider().
V-437-235
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 235
Description:
APP AT - Customer ID: 2 - An error occurred when requesting the PST COM object. System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
at KVS.EnterpriseVault.Interop.PSTProviderClass.OpenPSTEx(String PSTFileName, String PSTPassword, enumOpenMode ePSTOpenMode, Int32 Unicode, UInt32 MaxSizeMb)
at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.get_ThePSTProvider().
V-437-235
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 236
Description:
APP AT - Customer ID: 2 - [ExportPST] - Error moving MSG to PST for run 'Export Name' Number moved: 0. System.Runtime.InteropServices.COMException (0x8004010F): Exception from HRESULT: 0x8004010F
at KVS.EnterpriseVault.Interop.PSTProviderClass.OpenPSTEx(String PSTFileName, String PSTPassword, enumOpenMode ePSTOpenMode, Int32 Unicode, UInt32 MaxSizeMb)
at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.get_ThePSTProvider()
at KVS.Accelerator.Production.ProductionQueue.ProductionRunQueue.HooverUpMsgsToPst().
V-437-236
Cause
Compliance Accelerator (CA) and Discovery Accelerator (DA) exports to PST files throwing errors can be due to some issue with the Microsoft Outlook installation on the CA or DA server. Possible causes of the failures are typically on the CA or DA server and consist of, but are not limited to:
1. Antivirus scanning of the Vault Service Account's TEMP folder.
2. Antivirus scanning of the export folder.
3. Microsoft Exchange Security Patch KB959897 is installed on the CA or DA server.
Solution
For Causes 1 and 2:
If antivirus is scanning as files are written to the export folder, the scanning can block access to a PST file in order to write to it.
For Cause 3:
If the Microsoft Exchange (2003) System Manager (ESM) is installed on the CA or DA server with the Security Update for Exchange Server 2003 Service Pack 2 (KB959897) installed, an incompatible version of the mapi32.dll file will be installed on the server. The ESM is not required for CA or DA servers and should be uninstalled to prevent the installation of the Security Update (KB959897).
For all causes, one or more of the above events may be seen.
Troubleshooting:
-- Causes 1 or 2 --
1. Run a Dtrace on the CA or DA server of the AcceleratorService process. (Refer to 100038975 in the related documents section below.)
2. Locate the following sequence of events:
(pstprovider)StartPSTAccess() - PST message service added to the current profile
(pstprovider)StartPSTAccess() - An error occurred 0x8004010F
-- Cause 3 --
1. Log onto the CA or DA server as the Vault Service Account (VSA).
2. Open Control Panel.
3. For Windows Server 2003 installation,
a) Open Add or Remove Programs.
b) Click the Show Updates check box to place a check mark in it if not already present, allowing a few seconds for the programs listing to update.
4. For Windows Server 2008, including R2,
a) Open Programs.
b) Click on the Programs and Features link.
c) Click the View Installed Updates link.
5. Scroll through the programs to the Microsoft Exchange listing.
6. Scroll through the Security Updates to determine if Security Update for Exchange Server 2003 (KB959897) is present.
Solution:
-- Causes 1 or 2 --
Configure the antivirus software to exclude the export folder from being scanned.
-- Cause 3 --
1. Uninstall the Microsoft Exchange System Manager.
2. List the installed updates for all programs and ensure Microsoft KB 959897 has also been uninstalled. Uninstall if still present.
-- All Causes --
If still receiving errors, run FixMapi.exe from C:\Windows\system32 and restart the CA or DA server.