Unable to move messages to PST files during an Enterprise Vault (EV) Compliance Accelerator (CA) or Discovery Accelerator (DA) export run.
Problem
Unable to move messages to PST files during an Enterprise Vault (EV) Compliance Accelerator (CA) or Discovery Accelerator (DA) export run.
Error Message
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 234
Description:
APP AT - Customer ID: 2 - !!An error occurs during cleaning the PST object
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 235
Description:
APP AT - Customer ID: 2 - An error occurred when requesting the PST COM object. System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.
Event Type: Error
Event Source: Accelerator Service Processor
Event Category: None
Event ID: 236
Description:
APP AT - Customer ID: 2 - [ExportPST] - Error moving MSG to PST for run 'From Export Run (1)' Number moved: 0. System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.
Cause
CA and DA allow messages found and accepted in searches to be exported. The export options for Microsoft Exchange or SMTP messages are to MSG or EML format, PST or ZIP files, or HTML format. Exporting to PST files can fail with Event ID 234, 235 and 236 errors in the Enterprise Vault (EV) event log.
EV, CA and DA extract messages from storage and convert them to MSG, EML or HTML files on then EV server depending on the export format selected. The export process then uses the Microsoft Outlook instance on the server to move the MSG or EML files into PST files. For CA and DA exports, the conversion to MSG or EML files occurs on the EV Storage Service server, then these files are moved to the CA or DA server's export location. Once all of the MSG or EML files are present, the Outlook installation is used to hoover them into PST files. A supported version of Microsoft Outlook being installed on the CA or DA server is an installation requirement.
Note:
EML files will only be able to export into EML or ZIP files in the CA or DA 12.4.0 through 12.5.0 versions due to the lack of a built-in EML file previewer in Outlook. Starting with CA and DA 12.5.1, a feature is present to convert EML messages to MSG prior to moving them into PST files so that Outlook can preview them properly. EML files can also be moved into PST files but will not be able to be previewed natively in Outlook.
Solution
The following solutions exist for this issue:
- Install a supported version of Microsoft Outlook on the CA/DA server if one is not already installed. See the Enterprise Vault Compatibility List for information on supported versions of Microsoft Outlook that can be installed on an EV, CA or DA server.
- If a supported Outlook version is installed, restart the Enterprise Vault Accelerator Manager Service (EVAMS) service on the CA or DA server.
Note:
A supported version of Microsoft Outlook may include Microsoft patches and / or registry key entries such as REG_DWORD (32-bit Value) AttachmentMax and RecipientMax (each set to 0xffffffff hex) used to set the maximum number of attachments or recipients an e-mail can have.