Problem
STATUS CODE: 156 "snapshot error encountered" occurs when utilizing VSS for open file backups.
Error Message
Snapshot error encountered (156)
04:42:19.542 [840.5892] <2> onlfi_vfms_logf: snapshot services: vss:Fri Oct 2 2009 04:42:19.542000 <Thread id - 5892> VSS API ERROR:- API [DoSnapshotSetWorkItem:QueryStatus] status = 80042320 [DEFAULT]
04:42:19.542 [840.1692] <2> onlfi_vfms_logf: snapshot services: vss: "IVssBackupComponents::DoSnapshotSet" failed with error "VSS_E_NO_SNAPSHOTS_IMPORTED:(error value=0x
80042320)" while trying to commit snapshot set {7153CEB8-BE0B-43C1-8209-9F2F7FA32C3F}
04:42:19.542 [840.1692] <2> onlfi_vfms_logf: vfm_freeze_commit: vfm_method_errno=[6]
04:42:21.542 [840.1692] <32> onlfi_fim_split: VfMS error 11; see following messages:
04:42:21.542 [840.1692] <32> onlfi_fim_split: Fatal method error was reported
04:42:21.542 [840.1692] <32> onlfi_fim_split: vfm_freeze_commit: method: VSS, type: FIM, function: VSS_make
04:42:21.542 [840.1692] <32> onlfi_fim_split: VfMS method error 6; see following message:
04:42:21.542 [840.1692] <32> onlfi_fim_split: snapshot services: snapshot creation failed: provider-private error
Cause
If a backup on a Windows client fails with status code 156, this could indicate that the client is using Windows Open File Backups to protect open or active files. The volume "snapshot" that occurs to facilitate open file backup has failed. This failure is often caused by the VSS cache file running out of allocated space.
Solution
To confirm if VSS open file backups are activated:
- Within the NetBackup Administration Console, expand Host Properties in the right hand pane
- Within Host Properties, click Master Server and then the double-click the name of the Master Server in the right pane
- Click on the Client Attributes section
- If the client in question is listed here, click on the client name. If it is not listed, add and click on the client name.
- Click the Windows Open File Backup tab
- Ensure that Enable Windows Open File Backups for this client is not selected if open file backups are not required
![](https://veritastech.custhelp.com/euf/assets/images/100016953/image-1598266442241.png)
Another issue related to snapshot creation could be the size limit of Shadow Copies configured on the local drive.
For Volume Shadow Copy (VSS):
Use the following steps to increase the cache size when VSS is used on Windows 2003 Server clients.
- In Windows, right-click on the required local drive and select Properties
- In the pop up windows, click on Shadow Copies, select the appropriate drive letter, and then settings.
- In the Settings dialog box, change the Maximum Size setting to either No Limit or a size large enough to suit the requirements of the installation and usage of VSS
![](https://veritastech.custhelp.com/euf/assets/images/100016953/image-1598266177890.png)
Note:
In versions 7.0 and later VSP is no longer a valid snapshot method. These systems will need to utilize the VSS provider for snapshots.