DLO Agent remains in Disabled state, error - Dedupe engine offline.

Article: 100010525
Last Published: 2021-11-10
Ratings: 0 2
Product(s): Desktop Laptop Option

Problem

The Veritas Desktop and Laptop Option (DLO) agent is in a Disabled state with the error message:

Dedupe engine initialization failed. Please contact your system administrator.

Error Message

 

DLOClient.log files shows error:

Failed to login to Dedupe server.Error Code: 23522
 

DLOClient.log and DDEngine_1.log may also show:

Failed to login to Dedupe server.Error Code: 22020

Cause

This issue is caused because the client is not able to access Dedupe server or the Dedupe Storage Location on the DLO Admin Server.

Solution

Troubleshooting Tips:

To check whether Dedupe server is in accessible state:

  • Check whether the Dedupe Server is in ‘Active’ state. Enter the following URL in the browser.

HTTPS://DedupeServerHostName:8443

http://DedupeServerHostName:8080

  • Check whether the Mind tree Store Smart Dedupe Server Service is running on Dedupe server.

  • Check whether the password for Dedupe user account has been changed or expired (dedupe user account is the one which was used to add the Dedupe Storage Location (DSL). Update Dedupe account and/or password accordingly:

  • Check whether the Dedupe Server is in the Maintenance mode.

  • Login to the problematic client machine with dedupe user account and you should be able to access dedupe storage location (DSL).

After verifying all of the above steps, Exit and re-launch the DLO Agent and check to see if the issue is resolved.

  • If issue persist review the debug logs (DLOClient.log and DDEngine_1.log and look for the following errors.)
  • DLOClient.log (C:\Users\UserName\AppData\Local\Veritas\DLO\.settings)
    • Failed to login to Dedupe server.Error Code: 23522
    • Failed to login to Dedupe server.Error Code: 22020
  • DDEngine_1.log (C:\Users\UserName\AppData\Local\Veritas\DLO\.dlo\DedupeStore)
    • Error Code = 23022; Error Message = Could not connect to server host. 
    • Error Code = 23522; Error Message = The UserHashStore DB is not found
       

This particular Error Code is caused because the account used for the Dedupe Server on the DLO Console is not properly configured.

The Dedupe User should be a Domain User account that is also a Local Administrator of the DLO Admin Server. This account will also need to have Full Control to the DLOStorage folder as well as Full Control of the DLOStorage Share as follows:

  • Create a "Domain User" account (not a domain admin account)
  • Configure the account so that the password never expires
  • Set it as a local administrator on the box where the dedup storage location is
  • Give the account full control of the dedupe folder as well as the share for the dedupe folder
  • Also set the account as a local administrator on the server where the DLO administrator console is located
  • Restart all services on both the admin server and client after making changes
  • Also stop the DLOClientu.exe process in Task Manager on the client

References

Etrack : 3316509

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