After successful Bare Metal Restore (BMR) recovery, the client system fails to reboot with blue screen.

Article: 100001842
Last Published: 2014-12-04
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

After successful Bare Metal Restore (BMR) recovery, the client system fails to reboot, and displays a blue screen with Stop code 0x0000007B

Error Message

BSOD Stop Code (0x0000007B)

Cause

BMR clients that fail to properly reboot with BSOD Stop Code of 0x0000007B are having boot problems associated with the installed Mass Store Device (MSD) driver.

The restore configuration used to recover a client needs to have a MSD driver of the proper type and release that matches the hardware on the restored system.

During post processing of the BMR restore environment, the BMR code will perform checks to validate the restored systems hardware registry to match the hardware it was restored to. It will use the device driver information in the restore configuration to update the client system's registry for the subsequent reboot. A missing or invalid MSD driver will leave the client system in an unbootable state.

Another potential cause of this involves a mismatch between the OS version (architecture) of the BMR Windows boot image used (PXE or ISO) and that of the client backup image. A 32 bit Windows SRT image will not properly restore a 64 bit Windows OS backup image. The reverse is also true. If a proper Prepare to Restore is performed for a Windows client, the architecture of the SRT is used for the drop down menu choice of a client. As such only SRT entries that match the client's architecture will be displayed. If no SRT selections are displayed, then the BMRDB does not have a valid SRT for use.  

Any valid Windows Boot Server can produce an SRT of both 32 and 64 bit architecture, regardless of what its architecture is.

Solution

In order to properly recover the failed client, make the required changes to the restore configuration for the client, save the changes, run ‘Prepare to Restore’ on this changed configuration and then restart the BMR recovery. Ensure that the previous restore task is cleaned up prior to attempting another restore
 
For example, while recovering a DELL PowerEdge server, the device's percsas2 RAID controller card, was not included in restore configuration, resulting in the following error in the bmrrst log:
 
1 DEBUG deviceutils.cpp:GetRegHardwareIdsFromPnpInstanceId() Found acpiapic HAL:, making it acpiapic_mp, No. of processor(s): 8
4 DEBUG DeviceDb.cpp:winPeGetDriverInfo() Could not find inf info for the device ROOT\ACPI_HAL\0000. Possibly a non-critical device.
4 DEBUG CDsrStrategy.cpp:step() Current step=Processing MSDs
1 DEBUG CWinPeDsrStrategy.cpp:checkMsdDsr() Could not find the drivers for the following devices:PCI\VEN_1000&DEV_0073&SUBSYS_1F511028&REV_03 (percsas2)

The error in italics is non-critical and can be ignored.

For the error in bold text, locate/download the correct MSD driver for DELL’s percsas2 RAID controller card.

Then add this device driver to BMR DB using the Boot Server Assistant > Driver Package Wizard and then include this device in the restore configuration of BMR.

Note: The driver needs to be suitable for the target machine’s "DELL PERC RAID” controller device and for the correct OS version and OS architecture.


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