Problem
After performing a Discovery Accelerator(DA) upgrade to 14.x, a DA Customer will not upgrade and shows in a state of Update Failed
in the Info section of the Customer Properties Current Status pane in EVBAAdmin.
Error Message
The most frequently seen error message is:
Cannot find the object "dbo.tblContacts_X" because it does not exist or you do not have permissions.
An additional error may also be seen:
Cannot find the object "dbo.tblContacts_X" because it does not exist or you do not have permissions.
Warning! The maximum key length is 900 bytes. The index 'IX_tblContacts_DisplayName_EmailAddress' has maximum length of 1024 bytes. For some combination of large values, the insert/update operation will fail.
Possible EV Event Log entries:
Log Name: Veritas Enterprise Vault
Source: Accelerator Manager
Event ID: 59
Task Category: None
Level: Error
Keywords: Classic
Description:
APP ATM - Failed to update database. System.ApplicationException: Cannot find the object "dbo.tblContacts_X" because it does not exist or you do not have permissions.
at Symantec.Accelerator.DynamicSchemaManager.DynamicSchemaUpgrader.Start()
at KVS.Accelerator.Application.Install.UpdateDatabase(CustomerRow theCustomerRow, String configDSN)
V-437-59
Log Name: Veritas Enterprise Vault
Source: Accelerator Manager
Event ID: 64
Task Category: None
Level: Error
Keywords: Classic
Description:
APP ATM - Error upgrading a Customer. Install Thread - worker thread (X) Customer ID: X Number of tries: X Cause: Cannot find the object "dbo.tblContacts_X" because it does not exist or you do not have permissions.
V-437-64
Cause
There can be multiple causes, all stemming from the SQL Server. All Analytics functionality is performed by the SQL Server. Enabling Analytics creates a number of additional Analytics-associated tables in a new .ndf file and all Analytics full-text indexing and processing is then performed by SQL. Disabling Analytics deletes the Analytics-associated tables and full-text index created for the Analytics-enabled DA Case, and then updates the relevant statuses in the DA Customer database. If the Analytics-associated tables are not deleted and/or the status is not correctly updated in the DA Customer database, this issue is seen.
- Disabling Analytics for the Analytics-enabled CaseID noted after the underscore failed, leaving behind orphaned data. This is typically due to excessive SQL resource usage at the time Analytics was disabled or disabling too many Analytics-enabled Cases concurrently.
- Enabling Analytics for the Analytics-enabled CaseID noted after the underscore failed, causing the required Analytics tables not to be created.
For the additional error referencing the maximum key length, see the article titled Discovery Accelerator upgrade fails with SqlException 0x80131904 maximum key length is 900 bytes in the Related Articles below.
Solution
1. Collect the ConfigurationDBReport and CustomerDBReport from the Enterprise Vault, Compliance Accelerator and Discovery Accelerator Environment Reports article listed in Related Articles below.
2. Contact Technical Support for assistance with this issue.