Discovery Accelerator upgrade fails with SqlException 0x80131904 maximum key length is 900 bytes

Article: 100052261
Last Published: 2023-09-20
Ratings: 2 0
Product(s): Enterprise Vault

Problem

When upgrading an Enterprise Vault (EV) Discovery Accelerator (DA) Customer database, the upgrade fails and displays an error as below.

 

Error Message

- Error seen in the EVBAAdmin administration website in the Customer properties' Current Status pane:

Operation failed. The index entry of length X bytes for the index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' exceeds the maximum length of 900 bytes.
Warning! The maximum key length is 900 bytes. The index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' has maximum length of 1024 bytes. For some combination of large values, the insert/update operation will fail.

- Errors seen in the EV Event Logs on the DA server:

-- Event ID 64

APP ATM - Error upgrading a Customer.
Install Thread - worker thread (0)
Customer ID: X
Number of tries: 1
Cause: Operation failed. The index entry of length X bytes for the index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' exceeds the maximum length of 900 bytes.
Warning! The maximum key length is 900 bytes. The index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' has maximum length of X bytes. For some combination of large values, the insert/update operation will fail.
The statement has been terminated.

V-437-64

-- Event ID 59:

APP ATM - Failed to update database. System.Data.SqlClient.SqlException (0x80131904): Operation failed. The index entry of length X bytes for the index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' exceeds the maximum length of 900 bytes.
Warning! The maximum key length is 900 bytes. The index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' has maximum length of X bytes. For some combination of large values, the insert/update operation will fail.
The statement has been terminated.
at Symantec.EnterpriseVault.DatabaseAccess.EVSqlBase.Do[T](Func`1 action)
at Symantec.EnterpriseVault.DatabaseAccess.EVSqlCommand.ExecuteNonQuery()
at KVS.Accelerator.Application.Install.RunScript(String ScriptName, EVSqlCommand CMD, Int32 CustomerID)
at KVS.Accelerator.Application.Install.RunPatchUpdateScript(String scriptFile, EVSqlCommand CMD)
at KVS.Accelerator.Application.Install.UpdateDatabase(CustomerRow theCustomerRow, String configDSN)
ClientConnectionId:1234ABCD-12AB-34CD-56EF-123456ABCDEF
Error Number:1946,State:3,Class:16

V-437-59

-- Event ID 49:

APP ATM - Error Executing : \Program Files (x86)\Enterprise Vault Business Accelerator\<filename>.sql
Line: X
Failed to Execute the following command:

. . .

. System.Data.SqlClient.SqlException (0x80131904): Operation failed. The index entry of length X bytes for the index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' exceeds the maximum length of 900 bytes.
Warning! The maximum key length is 900 bytes. The index 'IX_tblContacts_<CaseID>_DisplayName_EmailAddress' has maximum length of X bytes. For some combination of large values, the insert/update operation will fail.
The statement has been terminated.
at Symantec.EnterpriseVault.DatabaseAccess.EVSqlBase.Do[T](Func`1 action)
at Symantec.EnterpriseVault.DatabaseAccess.EVSqlCommand.ExecuteNonQuery()
at KVS.Accelerator.Application.Install.RunScript(String ScriptName, EVSqlCommand CMD, Int32 CustomerID)
ClientConnectionId:1234ABCD-12AB-34CD-56EF-123456ABCDEF
Error Number:1946,State:3,Class:16

V-437-49

 

Cause

The issue is caused by data in the columns specified in the index that when combined exceeds the maximum allowable SQL limits.

 

Solution

The solution is to change the index type from a composite index, where multiple columns are listed as key columns, to a covering index, where one key column is listed as the main column and nonkey columns are listed as additional columns. Please contact technical support for assistance in resolving this issue.

Note - Upgrading to a version that contains the fix may still cause the issue to be seen during the upgrade. This is because the upgrade may include steps from intermediate versions between the current version and target version where those versions have the issue. For example, upgrading from 12.x to 14.3.0 may still exhibit the issue as certain steps from 14.2.0 are processed during the upgrade, with 14.2.0 having the issue. Please contact technical support for assistance in resolving this issue.

 

There are no plans to address this issue by way of a patch or hotfix in earlier versions of the software at the present time. However, the issue has been addressed in the revision of the product specified at the end of this article. 
 
Please contact your Veritas Sales representative or the Veritas Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.

 

This issue is fixed in the following release(s), available in the Download Center at www.veritas.com/support:
- Enterprise Vault 14.1.3 (downloadable here

- Enterprise Vault 14.2.1 (download no longer available)

- Enterprise Vault 14.3 

 

 

References

JIRA : CFT-4324 JIRA : CFT-4359 JIRA : CFT-4360

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