DLO 去重存储脱机,无法连接到去重服务器。

文章: 100060167
上次发布时间: 2023-08-30
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产品: Desktop Laptop Option

Problem

 

去重存储脱机,无法连接到去重服务器。

 

Error Message

 

在DLO admin console,右键点击去重存储 -> 管理,提示无法连接到服务器主机。

 

 

DLO去重存储服务器上的基本配置如果采用下图默认配置, 808084438009三个传输端口必须能够与DLO admin server建立连接。

 

登陆去重存储服务器,查看去重服务器监听端口,发现8443端口没有监听。如图:

 

Cause


导致8443端口无法监听的原因很多,请按照如下进行排查。

1  网络防火墙是否拦截了8443端口。

2  杀毒软件是否阻挡了端口的连接。

3  是否8443端口已经建立了监听,但是监听的进程不是DLO 进程(tomcat8.exe),而是被其他应用占用了该端口。

4 去重服务进程是否处于停止状态。 检查如下两个进程的运行情况,可以进行restart操作。

   

 

 

5  去重存储的数据库是否处于正常工作状态。如图:

 

 

6  检查一下去重存储安装路径下的 context.xml 文件配置是否与实际去重数据库名称一致。

    X:\Program Files\Veritas\Veritas DLO\Dedupe\Tomcat\webapps\DedupeServer\Meta-Inf\context.xml

检查如下的三个配置是否与实际配置名称一致,如果不一致需要修改。


以上是常规检查,如果都确认无误,那很可能就是DLO环境升级过程中出现server.xml配置文件异常。

 

Solution


DLO环境进行过版本升级或者安全hotfix修复等系统变更操作后,可能会出现配置文件错误,导致tomcat初始化异常,进而导致8443端口无法监听。

  • 首先登陆DLO Admin 服务器,进入下面路径,将server.xml文件复制到DLO去重服务器桌面

         X:\Program Files\Veritas\Veritas DLO\Dedupe\Tomcat\conf\server.xml

  • 登陆DLO 去重服务器,停止DLO服务。 

          Veritas DLO maintenance Service

          Mindtree StoreSmart Dedup Server

  • 进入DLO去重服务器的如下安装路径,将本地的server.xml名称修改为server_old.xml

         X:\Program Files\Veritas\Veritas DLO\Dedupe\Tomcat\conf\

  • 最后将DLO Admin 服务器上面的server.xml复制到相应位置,重启上述的两个服务

 

操作完成后,可以使用CMD窗口输入  netstat -ano | findstr "8443"  检查监听是否建立起来,如果建立起来后,DLO admin 服务器与DLO去重服务器之间的数据传输就可以正常使用。

 

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