Backup Exec Deduplication Storage Folder remains Offline even if all deduplication services are running
Problem
Backup Exec (BE) Deduplication storage folder shows OfflineError Message
Offline; This device has not been discovered correctly. Cycle the services on <Media Server Name> to retry device discoveryOR
Offline; Unable to connect to the OpenStorage device.Ensure that the network is properly configured between the device and the Backup Exec server
The Adamm log shows the following error(s):
DeviceIo Discovery - start
DeviceIo: STS: Critical: (Storage server: PureDisk:<Server Name>) NetConnectByAddr: Failed to connect to spoold on port 10082 using the following interface(s): [ <IPv4 or IPv6 or LoopBack address> ] (No connection could be made because the target machine actively refused it. ) Ensure storage server services are running and operational. V-454-92
DeviceIo: sts_open_server PureDisk:<ServerName> <Deduplication Username> 2060023
DeviceIo: ostaspi: sts_open_server PureDisk:<ServerName> as <Deduplication Username> error 2060023
DeviceIo: ostaspi: server PureDisk:<ServerName> has shut down
Cause
When Backup Exec Server is rebooted there may be an instance when the BE services starts sooner as compared to the Backup Exec Deduplication Engine service (spoold.exe). Due to this BE services may not discover the Deduplication Storage Folder as one of the deduplication services was still in a starting state.
Note : The Deduplication Engine service can take time to start as it builds the fingerprint cache from the Deduplication Storage Folder before it gets ready to accept data.The time to start the Backup Exec Deduplication Engine service depends on the occupied size of the Deduplication Storage Folder. More the deduplication folder is occupied, it will need to load more fingerprints in the memory and can take longer. The memory consumed by spoold.exe when viewed in task manager would show that it is constantly increasing when this service is in starting state.
Solution
If the Backup Exec Deduplication Engine service shows "Starting" in Windows Services console follow step 1. If the Deduplication related services are all started then skip step 1 and follow step 2 and 3.- Wait for the Backup Exec Deduplication Engine service to start successfully
- Confirm if Spoold is actually up and running by executing below command from BE Install Path in command prompt. If the output shows as below that means spoold is completely up and ready to accept data and proceed to Step 3.
BE 2014, 15, 16 will show below output which denotes dedupe state is fine --
Mode : GET=Yes PUT=Yes DEREF=Yes SYSTEM=Yes STORAGED=Yes REROUTE=No COMPACTD=Yes RECOVERCRDB=No
BE 20 Dedupe getmode outout --
C:\Program Files\veritas\Backup Exec>crcontrol.exe --getmode
Mode : GET=Yes PUT=Yes DEREF=Yes SYSTEM=Yes STORAGED=Yes REROUTE=No COMPACTD=Yes
BE 21 Dedupe getmode output --
C:\Program Files\veritas\Backup Exec>crcontrol.exe --getmode
Mode : GET=Yes PUT=Yes DEREF=Yes SYSTEM=Yes STORAGED=Yes REROUTE=No COMPACTD=Yes FIPS=No KMS=No
If the status shows different or an error appears review the following technote ( 000108128), else contact technical support for assistance
- Restart the Backup Exec services from the BE Services Manager (BE icon -> Configuration and Settings -> Backup Exec Services) to initiate the discovery of Deduplication Storage folder. This will allow Backup Exec to successfully discover the deduplicaiton storage folder and show it as "online".
Note: For the deduplication folder to show "online" all deduplication services need to be started and Deduplication Storage folder should be free from any corruptions.