Problem
Items are awaiting backup after a full backup has been completed.
Error Message
After a full backup of Enterprise Vault partitions there are still messages pending in users mailboxes.
When viewing the Vault Usage report items are awaiting backup in the report.
Further investigation shows the Watchfile table in the Vault Store database contains records.
Cause
This can be caused by the backup software not resetting the Archive attribute as part of the backup process.
Solution
The following commands will create a text file that will verify if the archive bit has been reset or not.
Either command needs to be run in the root directory of the Vault Store Partition:
From the CMD line prompt
attrib /s > C:\attrib_log.txt
The above command will return all files in the folder structure below the Partition Root Path location. All files of interest will appear as the below example Output
Example Output
A G:\Express Vault Store\Express Vault Store Ptn1\2009\01-04\E\056\E05697B9C1513608FDF6F639253380C1.DVS
A G:\Express Vault Store\Express Vault Store Ptn1\2009\01-04\E\056\E05697B9C1513608FDF6F639253380C1~80~5A0657C7~00~1.DVSSP
A G:\Express Vault Store\Express Vault Store Ptn1\2009\01-04\E\056\E056A273BF4C723CD9C196E2FD81D761.DVS
From the Powershell Console
Get-ChildItem -recurse | Where{$_.Attributes -like "*Archive*"} | Select FullName, Attributes | FT -AutoSize | Out-File C:\attrib_log.txt
The above Powershell command will only return files which do have the Archive attribute still set
Example Output
E:\FSA Vault Store\Ptn1\2016\03-10\7\078\7078EE57997769E028ADCF7D737612E1.DVS Archive
E:\FSA Vault Store\Ptn1\2016\03-10\7\078\7078EE57997769E028ADCF7D737612E1~F5~56073CF2~00~1.DVSCC Archive
E:\FSA Vault Store\Ptn1\2016\03-10\7\078\7078EE57997769E028ADCF7D737612E1~F5~56073CF2~00~1.DVSSP Archive
E:\FSA Vault Store\Ptn1\2016\03-10\7\079\70790300A3BD6AE8B4FD1450DED58151.DVS Archive
If the Archive attribute has not been reset, verify the backup software configuration and confirm that the Archive bit is being reset correctly. If the backup software does not support removing the Archive bit, then the backup administrator will need to implement the trigger file mechanism. See the Related articles section for more information.