La copia de seguridad de Microsoft SQL Server falla con el error "La interfaz de dispositivo virtual (VDI) de Microsoft SQL Server no se ha podido iniciar"

Artículo:: 100037306
Última publicación: 2018-05-04
Clasificaciones: 1 0
Producto(s): Backup Exec

Problema

V-79-57344-860 - La copia de seguridad de Microsoft SQL Server falla con el error "La interfaz de dispositivo virtual (VDI) de Microsoft SQL Server no se ha podido iniciar"

Mensaje de error

El registro de trabajo de copia de seguridad muestra lo siguiente:

Error final: 0xe000035c - La interfaz de dispositivo virtual (VDI) de Microsoft SQL Server no se ha podido iniciar.  Esto, a menudo, se ocasiona por no tener instalado el Service Pack de SQL ni la corrección que se requiere.  La ejecución de SQLExpress en Windows Vista o Windows Server 2008 requiere Service Pack 2, además de la corrección V4 o posterior.

Categoría de error final: Errores de recurso

Para obtener información adicional sobre este error, consulte el vínculo V-79-57344-860 

 

 El registro de aplicación de Windows en SQL Server informará uno de los siguientes eventos:
 EventID: 1
 Source: SQLVDI
 Description:
 SQLVDI: Loc=CVDS::CreateEx. Desc=Security initialization failed.ErrorCode=(0). Process=3468. Thread=2556. Client. Instance=.    VD=Global\BPC_SQL_00__7bc4ef5b_1c89_4392_95e5_6b890ac71ec0_.
 

 EventID: 1
 Source: SQLVDI
 Description:
 SQLVDI: Loc=ShareProcessHandle. Desc=GetSecurityInfo. ErrorCode=(5)Access is denied. Process=3468. Thread=2556. Client.
O

0xe0008443 -> Una o más comprobaciones de coherencia de base de datos SQL han fallado.

Estado terminado: Error
Error final: 0xe000035c - La interfaz de dispositivo virtual (VDI) de Microsoft SQL Server no se ha podido iniciar. Esto, a menudo, se ocasiona por no tener instalado el Service Pack de SQL ni la corrección que se requiere. La ejecución de SQLExpress en Windows Vista o Windows Server 2008 requiere Service Pack 2, además de la corrección V4 o posterior.
Categoría de error final: Errores de recurso

Para obtener información adicional sobre este error, consulte el vínculo V-79-57344-860

 

Causa

El mensaje de error mencionado anteriormente se puede encontrar durante una copia de seguridad de SQL Agent local o remota, incluso después de que se haya confirmado que todos los Service Packs y las correcciones de SQL se han aplicado si se han producido las siguientes condiciones:

A. El archivo sqlvdi.dll no está registrado correctamente en Windows.
B. El servidor SQL forma una parte de un dominio y las credenciales de inicio de sesión utilizadas para el servicio de SQL Server se encuentran en la forma/Administrador.
C. Este error también se produce cuando se realiza una copia de seguridad de Microsoft SQL Server 2005 que se ejecuta en Windows Server 2008.
D. La base de datos tiene algunos errores de DBCC. 

Solución

De acuerdo con el mensaje de error, asegúrese de que el servidor SQL cuente con todos los parches necesarios. Consulte el sitio de asistencia técnica de Microsoft SQL para encontrar las últimas actualizaciones de SQL Server. Si el problema continúa, consulte las respectivas soluciones:

A:  Registro de SQLVDI.dll
         
               1. Detenga todos los servicios de SQL.
               2. Inicie Windows Explorer, busque y documente la ubicación de cada instancia de sqlvdi.dll.
               3. Haga clic en Inicio y en Ejecutar, escriba Regsvr32 Path\SQLVDI.DLL en el cuadro Abrir y, a continuación, haga clic en Aceptar.
               4. Reinicie SQL Server.
 
Nota:  La ruta predeterminada del archivo Sqlvdi.dll es C:\Archivos de programa\Microsoft SQL Server\80\COM, pero el archivo puede estar en una ubicación diferente, o puede existir más de uno; por ello, registre cada uno que encuentre en la búsqueda realizada en el paso 2 anterior.
 
 
B:   Para cambiar las credenciales de inicio de sesión para el servicio SQL.
                1: Cambie las credenciales de inicio de sesión para el servicio de SQL Server a /Administrador.
         
Para obtener más información sobre la solución de problemas de conectividad de SQL, consulte los siguientes artículos de Microsoft:
 
Cómo solucionar problemas de conectividad en SQL Server
 
Nota: Si se produce el mismo error en una copia de seguridad remota de SQL después de realizar los pasos anteriores, desinstale Backup Exec Remote Agent for Windows Servers (RAWS), reinícielo, vuelva a instalar RAWS y ejecute otra copia de seguridad.
 
 
C:  Ejecución de SQL 2005 en Windows Server 2008
       Cambie la cuenta de inicio de sesión del "servicio de escritura VSS de SQL Server" en SQL Server para utilizar una cuenta de administrador de dominio.
                 1. Haga clic en Inicio - Ejecutar.
                 2. Escriba services.msc.
                 3. Seleccione el servicio de escritura VSS de SQL Server.
                 4. Abra Propiedades y seleccione la ficha Inicio de sesión. Cambie la cuenta del sistema local a una cuenta de administrador de dominio.
                 5. Reinicie los servicios de Backup Exec en SQL Server y pruebe las copias de seguridad.
 
D:  Compruebe la base de datos en cuestión en busca de un error DBCC:
1. Compruebe la base de datos en cuestión en busca de un error DBCC. Ejecute la siguiente consulta en SQL Server Management Studio:

DBCC CHECKDB (DatabaseName) WITH NO_INFOMSGS, ALL_ERRORMSGS

2. Corrija los errores de DBCC en los errores de consulta anteriores.

 

Nota: Si todas las otras soluciones fallan, quizá sea necesario realizar una instalación de reparación de la última versión de SQL que se haya instalado en el sistema.

 

 

Referencias

Etrack : 1 UMI : V-79-57344-860 Etrack : 0xe000035c Etrack : 0xe0008443

¿Fue útil este contenido?