V-79-57344-38211 - "0xe0009543 - Cannot get the configuration details of a VMWare virtual machine" when using the Agent for VMware Virtual Infrastructure and VMware VirtualCenter.

Article: 100019739
Last Published: 2018-05-03
Ratings: 1 2
Product(s): Backup Exec

Problem

"0xe0009543 - Cannot get the configuration details of a VMWare virtual machine" when using the Agent for VMware Virtual Infrastructure and VMware VirtualCenter.  Additionally, a "test run" job when performed for this backup may incorrectly displayed as successful.

Error Message

0xe0009543 - cannot get the configuration details of a VMWare virtual machine

UMI:  V-79-57344-38211

 

Similar error can occur during GRT enabled backup of the VM:

e0009543 - Cannot get the configuration details of a VMware virtual machine.

 

Job log may show following errors too:

Note: Resource: "VMVCB::\\VCenter\.....\vm\<Virtual machinename>" is not snappable. Attempting to back up directly from the source volume.

Cause

  1. The above error would occur if the user account specified for the backup does not have enough access in VMWare VirtualCenter to perform the backup.
  2. The above error would occur if the disk where the VM is located is a GPT (GUID Partition Table) volume. (unsupported)
  3. Inconsistency in selection set between what is listed under "View by Resource" tab and items listed under "View selection details" tab. If a Virtual Machine is moved to another folder under "VM and templates" view, it will create the inconsistency in backup selection list as it may still be listed in "View Selection Details" tab under original folder it was backed up from initially.
  4. The above error would occur if one or more virtual machines have been moved to a different ESX host and the previous non existent entries remain on the view selection list details.
  5. The remote agent is not installed on the virtual machine(s) or not publishing to the media server. The trust is not established between the virtual machine(s) and the media server. This issue may also occur if there is change in the name of server and the selection list is not modified. Ensure that in View Selection Details its shows the updated server name.
  6. This may occur if ESX datastore was recovered / restored and / or ESX  server was deleted and then re-added in VSphere client.

Solution

Solution 1:
The user account specified for the backup of the virtual machine needs the following Roles in Virtual Center:
Open vCenter server with vSphere Client. On the address bar, select Home>Administration>Roles.

  • VirtualMachine>Configuration>Disk Lease
  • VirtualMachine>State>Create Snapshot
  • VirtualMachine>State>Remove Snapshot
  • VirtualMachine>Provisioning>Allow Virtual Machine Download
  • VirtualMachine>Provisioning>Allow Read-only Disk Access

     

For the Agent for VMware Virtual Infrastructure to be able to backup using an account in VirtualCenter not assigned to the Administrator role, the "Browse Datastores" rights needs to be added to the role the user is assigned to.

After all required rights have been applied to the role, the permissions for the user defined for the backup will need to be added at the "Hosts and Clusters" level in VirtualCenter.

Additionally, it is required that the account specified be a Local Administrator (directly, not by association with a group) on the Virtual Center and VMWare Consolidated Backup Proxy.

 

Solution 2:

The above error would occur if the disk where the Virtual Machine is located is a GPT (GUID Partition Table) volume, where GPT volumes are not supported with Backup Exec 2010. However it is supported with Backup Exec 2012 version onwards.

 

Solution 3:

Remove old reference of the Virtual Machine under "View Selection Details" tab from incorrect folder and again select the Virtual Machine correctly under "View by Resource" from the current folder where Virtual Machine resides and save the selection list.

 

Solution 4:

  • Test   Resource credentials   on the selection list in the backup job and note the selection on which failing.
  • Check under   View by resource in backup job, if the selection exists. If yes delete the entries of the virtual machines for the ESX host which are not existing.
  • Alternately it would be a better practice to recreate the selection list.
  • It is advisable to select the virtual machine to backup from vCenter instead of ESX host in the backup job if V-Motion is configured on the ESX servers.

 

Solution 5:

  • Install the Remote Agent on the virtual server(s) in question.
  • Enable publishing to the media server.
  • Enabling publishing shoud automatically create trust between the virtual machine(s) and the media server.

Refer to the Related Articles for more information.

 

Solution 6:

  1. Check the backup selection list to see if affected virtual machine appears there. It may not appear at it's original location but under "Discovered Virtual Machines"
  2. Select the virtual machine in question from "Discovered Virtual Machine" node in the backup selection list
  3. Click "View Selection Details" tab and delete old entry for this virtual machine in question.
  4. Click Submit.
  5. Re-try the job.
 

 

References

UMI : V-79-57344-38211 Etrack : 1957804 Etrack : 0xe0009543

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