問題
Hyper-V 仮想マシンのバックアップでクラッシュの一貫性チェックポイントが作成された例外処理が発生することがあります。
注意:バックアップジョブは成功、例外処理ありの状態であり、失敗ではありません。ただし、クラッシュの一貫性チェックポイントであるため、仮想マシン内のファイル単位のリカバリは可能ですが、仮想マシン内のデータベース (GRT としてサポートされている VSS アプリケーション) のリカバリは実行できません。
エラーメッセージ
Backup Exec は「仮想マシン名」仮想マシンのアプリケーションの一貫性チェックポイントの作成に失敗し、クラッシュの一貫性チェックポイントを作成しました。この問題は、VSS スナップショットのエラーにより発生する可能性があります。アプリケーションの一貫性チェックポイントのエラーが発生しているイベントがあるかどうかを調べるには、Hyper-V ホストで Hyper-V-VMMS 管理イベントログを参照するか、ゲスト仮想マシン内の VSS 操作に関連するアプリケーションイベントログを参照してください。
V-79-57344-38769 - 仮想マシン '仮想マシン名' はオフラインバックアップを使用してバックアップされたため、VHD / VHDX ファイルの一貫性はクラッシュに対してのみ維持されます。ファイルレベルのリカバリを実行できますが、予測できない結果になる可能性があります。この仮想マシンのアプリケーションレベルのリカバリは実行できません。
原因
Hyper-V 統合サービスの ”バックアップ (ボリューム シャドウコピー)” サービスを無効に設定した場合に発生します。
図1
解決策
1.Hyper-V マネージャーを開き、仮想マシンの設定画面を開きます。
2.統合サービスを選択し、図1 で示した”バックアップ (ボリューム シャドウコピー)” サービスにチェックを入れ、設定を保存します。
3.仮想マシン OS にログインし、"Hyper-V Volume Shadow Copy Requestor" サービスを再起動します。
4.Backup Exec による仮想マシンのバックアップを行い、例外処理が発生しないことを確認します。