Exchange Mailbox Restore to PST fails with 0xe000ff12 - A communications failure has occurred with an Exchange Store resource.
Problem
Users attempting to restore Exchange mailboxes from cataloged and verified backup sets to PST files encounter persistent failures. The issue occurs regardless of whether the PST file is being restored to the local backup server or remote machines. The Backup Exec Remote Agent (beremote.exe) crashes during Exchange mailbox restores to PST files.
Error Message
The following error messages are logged during the restore process:
Final error: 0xe000ff12 - A communications failure has occurred with an Exchange Store resource.
Restore Set Detail Information: V-79-57344-65298 - The Exchange Store service is not responding. Backup set canceled.
Application Event Log:
Application Error
Application Error
Event ID: 1000
Faulting application name: beremote.exe, version: 25.0.1193.0, time stamp: 0x679232c0
Faulting module name: bedsmbox.dll, version: 25.0.1193.0, time stamp: 0x679232b9
Exception code: 0xc0000005
Fault offset: 0x000000000003d0e9
Faulting process id: 0x2d34
Faulting application: RemSrv64.exe 25.0.1193.0
Faulting module: ??? ???
Fault offset 0
Exception code 0."
Cause
The remote agent service terminates when processing certain mailbox item properties during the restore operation to a PST file.
Solution
A supported hotfix has been made available for this issue. Please contact Technical Support to obtain this fix. This hotfix has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix.
The Product Engineering Team currently plans to address this issue by way of a patch or hotfix to the current version of the software. Please note that we as a company reserve the right to remove any fix from the targeted release if it does not pass quality assurance tests. Our plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
Please contact your Sales representative or the Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.