All share scans across all devices are hung after upgrading to Data Insight 7.1

Article: 100074101
Last Published: 2025-04-01
Ratings: 0 0
Product(s): Data Insight

Problem

Scans are not progressing for any device after upgrading to Data Insight 7.1

Error Message

There are no error messages.

But, we can see the following behavior in the logs:

From the commd log analysis it is observed that for all the shares added prior to version 7.1 we are getting a thread count of 0 in ScannerV3 command.

C:\Program Files\DataInsight\/bin/scannerv3.exe, 9, 195, 389, 149535, 1, \\?\UNC\<FILE SERVER>\<SHARE>\, 0, HD00, xx02, __PASSWORD_FROM_STDIN__, "d:/DataInsight/data", "d:\DataInsight\data\outbox", "C:\Program Files\DataInsight\\log\scanner", 0, 0, 100000, 1, __SCAN__, 1, 0, 0, 0, 0, 0, 0, 0

But if the same share is added after upgrading to version 7.1, the correct thread count of 2 is shown.

C:\Program Files\DataInsight\/bin/scannerv3.exe, 9, 195, 389, 150028, 1, \\?\UNC\<FILE SERVER>\<SHARE>\, 0, HD00, xx02, __PASSWORD_FROM_STDIN__, "d:/DataInsight/data", "d:\DataInsight\data\outbox", "C:\Program Files\DataInsight\\log\scanner", 2, 2, 100000, 1, __SCAN__, 1, 0, 0, 0, 0, 0, 0, 0

Cause

Shares added prior to 7.1 are missing the parallel.thread.count property after the upgrade and the default value of 0 is used.

Shares added after upgrading to version 7.1 are assigned the correct value of 2 for the parallel.thread.count property.

 

Solution

This is resolved in version 7.1.1 and newer releases.

References

JIRA : CFT-7123

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