NetBackup IT Analytics - Unknown error executing bpgetconfig

Article: 100074070
Last Published: 2025-03-19
Ratings: 0 0
Product(s): NetBackup IT Analytics, NetBackup & Alta Data Protection

Problem

All NetBackup IT Analytics Data Collection probes fail to collect data.
 

Error Message

17 Mar 2025 13:20:34:829 ERROR 11024 main:SecurityDetailsProbe:nbserver1 DriverConfigManager.getDriverConfigWithDriverNameInIt:145 - Caught a DriverException while getting the appropriate driver.
com.aptare.dc.spi.driver.DriverException: Unknown error executing bpgetconfig


 

Cause

Since this is affecting all probes, the most common issue is that the Primary Server User ID doesn't have enough access or privileges to run the NetBackup commands needed for data collection.

 

Solution

Log on to the NetBackup primary server and verify that the service account is set up and the Primary Server User ID has sudo access per online documentation below:

If Primary is on BYO - Configure NetBackup sudo access for NetBackup data collectionhttps://www.veritas.com/support/en_US/doc/140248394-166019502-0/v142365979-166019502

If Primary is on NetBackup Appliance - Configure NetBackup Appliances for Data Collection: https://www.veritas.com/support/en_US/doc/140248394-166019502-0/v143524453-166019502

If Primary is on Flex Appliance - Configure NetBackup Flex Appliances for Data Collection: https://www.veritas.com/support/en_US/doc/140248394-166019502-0/v143662741-166019502

 

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