Backup Exec management service crashes after upgrade to Backup Exec 25

Article: 100073475
Last Published: 2025-02-17
Ratings: 0 3
Product(s): Backup Exec

Problem

Backup Exec management service crashes after upgrade to Backup Exec 25

Error Message

Application Event log :

Source:        .NET Runtime
Event ID:      1026
Task Category: None
Level:         Error
Keywords:      Classic
Description:
Application: BackupExecManagementService.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.NullReferenceException
   at BackupExec.Management.Components.Job.JobManager.CreateSelfProtectBackupJob(System.Object)
   at BackupExec.Management.Components.Common.TaskHelper+TimerContext.TaskHandler(System.Object)
   at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean)
   at System.Threading.TimerQueueTimer.CallCallback()
   at System.Threading.TimerQueueTimer.Fire()
   at System.Threading.TimerQueue.FireNextTimers()

 

Source:        Application Error
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
Description:
Faulting application name: BackupExecManagementService.exe, version: 25.0.1193.0, time stamp: 0x6792332d
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00007ff8c57e1e16
Faulting process id: 0x221c
Faulting application start time: 0x01db77b2197b1087
Faulting application path: C:\Program Files\Veritas\Backup Exec\BackupExecManagementService.exe
Faulting module path: unknown

 

Cause

Backup Exec 25 creates a self-protect job to backup the backup exec configuration. This job could not be created after the upgrade and hence the backup exec management service crashed. 

Solution

1) Start the Backup Exec Management service. It remains started for a few minutes.

2) Add the Fully Qualified Domain name of Backup Exec server to Backup and Restore Tab using the Add Server button.



3) Restart all BE services after the FQDN of Backup Exec server gets added successfully.  

If the issue is still not solved with the above steps, please contact Technical Support.

 

This issue is presently under investigation by our Engineering Team. Depending on the results of this investigation, it may be addressed through a patch or hotfix in current or future software releases. However, this specific issue is not currently scheduled for inclusion in any upcoming release. If this issue has a significant business impact on your continued use of the product, please contact your Sales representative or the Sales team to discuss your concerns.
 
Note: Customers experiencing this issue are encouraged to contact Veritas Technical Support as data is still being collected to assist in resolving this issue.

References

Etrack : 4188219

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