Microsoft 365 exchange online or one drive consolidation job fails with "0xe0000904 - An error occurred while retrieving catalog information."
Problem
Microsoft 365 exchange online or one drive consolidation job fails with "0xe0000904 - An error occurred while retrieving catalog information."
Error Message
Job Log reports the following error:0xe0000904 - An error occurred while retrieving catalog information
Cause
The Exchange Online backup had a user in backup selection without an activated mailbox. During consolidation, this mailbox selection caused an invalid selection error and thus caused the failure.
In the case of one-drive consolidation, some selections which were unchanged did not create a corresponding entry in those incremental leading to a failure for those selection in consolidation job.
Solution
The issue mentioned in this technote is different from the one documented below :
https://www.veritas.com/support/en_US/article.100062629?
https://www.veritas.com/support/en_US/article.100071174?
A supported hotfix has been made available for this issue. Please contact Technical Support to obtain this fix. This hotfix has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix.
The Product Engineering Team currently plans to address this issue by way of a patch or hotfix to the current version of the software. Please note that we as a company reserve the right to remove any fix from the targeted release if it does not pass quality assurance tests. Our plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
Please contact your Sales representative or the Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.