NBFS - Storage - Excess checkpoints for NetBackup Primary Server storage due to leftover lock files

Article: 100073080
Last Published: 2025-01-22
Ratings: 0 0
Product(s): Appliances

Problem

On NetBackup Flex Scale clusters with a Primary Server instance the catalog data is protected using checkpoints.

Once the total number of checkpoints exceeds 36, the oldest checkpoint is removed and a new checkpoint is created.

When a node is shutdown or restarted via the Web UI, cleanup of old checkpoints is suspended.

In some cases, when the node is brought back online after rebooting, a status flag from the reboot is not removed.

This may cause cleanup of old checkpoints to remain suspended indefinitely, resulting in excess storage utilization.

 

Error Message

This condition can result in excess storage utilization for the NetBackup Primary Server instance.

As a result, you may receive a storage use alert for the NetBackup Primary Server.

 

Cause

Cleanup of Primary Server checkpoints may remain suspended following node reboot due to a leftover touch file.

The quantity of Primary Server storage checkpoints may exceed the maximum amount, resulting in high storage use..

 

Solution

An EEB has been provided to prevent the occurrence of the issue on the NBFS 3.2 and NBFS 3.2.100 releases.

Following installation of the EEB log messages will be generated to reflect if:

  • Leftover touch files are present on the cluster
  • Excess checkpoints are present on the cluster

The log messages will be present in the Appliance VxUL logs under OID 1. 
 

Example - Log Message - Excess Checkpoints:

There are <NUMBER> snapshots of MASTER_FS which is more than expected. Please contact Technical Support and reference Technote article 100073080.

Example - Log Message - Leftover Touch Files

Touch file(s) /log/VRTSnas/node.is.going.down.flag* exists on this node, <HOSTNAME>. Please contact Technical Support and reference Technote article 100073080.

Removal of leftover touch files will allow the automated checkpoint cleanup process to resume.

Once the touch files have been removed, monitor the cleanup process to confirm if the checkpoints are being removed.

If the checkpoints are not removed automatically, contact Veritas support to assist with checkpoint removal. 

 

References

JIRA : APPCFT-15753 JIRA : IA-57717 Etrack : 4188606

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