Enterprise Vault Outlook Add-in on Windows 11 generates error 'There was a problem starting [EVMSP32.dll]. The operating system cannot run %1'
Problem
Installing the Enterprise Vault Outlook Add-in on Windows 11 24H2 x64 generates an error for 32-bit Outlook editions. The installation will finish, but Virtual Vault functionality doesn't work. The 64-bit Outlook editions are not affected.
Error Message
Error during installation:
---------------------------
RunDLL
---------------------------
There was a problem starting C:\Program Files (x86)\Enterprise Vault\EVClient\EVMSP32.dll
The operating system cannot run %1.
---------------------------
OK
---------------------------
When attempting to enable Virtual Vault after installation, users may see the following error in the Outlook UI:
---------------------------
Enterprise Vault
---------------------------
Enterprise Vault could not add or remove the following Virtual Vaults:
[UserName]
Try again later.
---------------------------
OK
---------------------------
Cause
Windows 11 Version 24H2 is currently pending certification for use with Enterprise Vault clients. There is an apparent incompatibility between this version of Windows and the Outlook Add-in.
Solution
This issue has been resolved in Enterprise Vault 15.1.2, available from Downloads.