Special characters %, : and / are not supported in the password for the NBDB, BMRDB, or NBAZDB database

Article: 100071648
Last Published: 2024-12-04
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

A NetBackup upgrade from a version earlier than 10.2 fails if the NBDB database password contains the following special characters:

'%'  (or)  '/'  (or)  ':'

Error Message

If an upgrade fails because there are special characters in the NBDB, BMRDB, or NBAZDB database password, users see the following error message:

ERROR: NetBackup database creation failed!

Cause

Incorrect encoding of special characters (% : /) when a connection string is built for PostgreSQL. 

Solution

  1. Follow the instructions in the NetBackup Installation Guide to perform a disaster recovery install and catalog recovery of the NetBackup primary server.
  2. To correctly build connections to PostgreSQL, update the SQL Anywhere password as follows. Ensure to exclude the special characters that are mentioned earlier.

    To update the NBDB or the BMRDB database password:
    nbdb_admin -dba mypassword

    To update the NBAZDB database password:
    nbdb_admin -dba mypassword -dbn NBAZDB
     
  3. Restart the NetBackup services.
  4. Perform the upgrade again.

There are no plans to address this issue by way of a patch or hotfix in earlier versions of the software at the present time.  However, the issue has been addressed in the revision of the product specified at the end of this article. 
 
Please contact your Sales representative or the Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.

NOTE: NetBackup 10.5 includes a fix to correctly encode special character '%' in the database password.

References

Etrack : 4175606

Was this content helpful?