Issues when accessing or restoring files from copied or moved stubs (.stub.url) in SharePoint Online

Article: 100069243
Last Published: 2024-07-25
Ratings: 0 0
Product(s): Veritas Alta SaaS Protection

Problem

When a  stub (.stub.url file) is copied or moved to another location or restored back from Recycle Bin in SharePoint Online (SPO) the user may encounter the following issues while downloading and/or restoring in Veritas Alta SaaS Protection (ASP) :

Issue 1: The corresponding file is not available in the new location in ASP Content Tab 

Issue 2: If an end user tries to initiate a restore from the stub from SPO, the restore may fail. The Restore dashboard for that restore will display the following error: 
There was an error restoring the file from the stub. Check if the '/sites/ABC/List/ sales-sample-data.docx' is present in SharePoint. The stub file may have moved from the original location. Retry the restore from the VASP Administration portal.

Issue 3: For restores initiated from the ASP Administration Portal, depending on the options selected, the stub file in SharePoint may not be replaced by the original file from ASP. 

Issue 4: The file in ASP may not be accessible using the corresponding ASP stub in SPO (see below) or may not be seen in the End-User Portal if the user does not have permission to access the original file in ASP. 

 

Error Message

You do not have access or the appropriate permissions to view this file stub. Contact your Alta SaaS Protection Administrator to update your permissions. 

There was an error restoring the file from the stub. Check if the '/sites/ABC/List/ sales-sample-data.docx' is present in SharePoint. The stub file may have moved from the original location. Retry the restore from the VASP Administration portal.

 

Cause

ASP does not track copying or moving stubs to a new location in SPO. It does not backup information and update permissions for these stubs in ASP. If the stubs are moved, the corresponding items in ASP, will be present at their original location but will be marked as Removed from source.

 

Solution

Issue 1: Check if the corresponding file in ASP can be located by browsing the Content tab to its original location (if already known) or using search (the user will have to remove the .stub.url from the file name). If there is difficulty locating the content, please contact Technical Support.

Once located, files can be downloaded or restored using the ASP Administration Portal or End-User Portal, depending on user permissions from the original location.

 

Issue 2: In this case, the Administration Portal restore can be used to perform a redirected restore. See details below.

 

Issue 3: For restores initiated from the ASP Administration Portal, depending on the options selected, the stub file in SPO may not be replaced by the original file from ASP. 

Depending on the use case, ASP supports the redirected restore of files to another SPO location. In all cases the Suppress ‘Removed from source’ check box should not be selected.

 

If only the stub needs to be restored back to its file in the locations where it was moved to:

  • Select the file in the ASP Content tab from its original location 

  • Clear the Suppress ‘Removed from source’ check box, if the option is available. 

  • Select the Restore only stubbed items check box. 

  • Select the Restore all versions check box, if required. 

  • Select the parent folder in the destination where the stub has been moved . It should have the same name (except ends with .stub.url). 

  • Perform the restore. 

Notes

  • If the user is restoring the file to the destination document library having stub with the same name, then stub will be replaced with the original file. 

  • The file will not be restored to destination if the Restore only stubbed items option is selected and the corresponding stub file is not available at the destination. 

 

If a folder containing the stubs was moved to a different location and only the stubs in that moved folder need to be restored: 

  • Select the folder in the ASP Content tab from its original location. 

  • Clear the Suppress ‘Removed from source’ check box, if the option is available. 

  • Select the Restore only stubbed items check box. 

  • Select the Restore all versions check box, if required. 

  • For the destination, select the parent folder of the destination folder containing the stubs which have been moved. 

  • Perform the restore 

Notes

  • If the user is restoring the file to the destination document library having stub with same name, then stub will be replaced with original file. 

  • Only those stubs in the destination will be restored whose paths match within the selected sub-hierarchy of the source folder. 

  • File will not be restored to destination if the Restore only stubbed items option is selected and the corresponding stub file is not available at the destination in the same path as the source. 

 

If just the file needs to be restored to the original/different location:  

  • Select the file in the ASP Content tab from its original location. 

  • Clear the Suppress ‘Removed from source’ check box, if the option id available. 

  • Select the parent folder in the destination where the restore needs to be done. 

  • Perform the restore. 

 

Issue 4: Please contact Technical Support for assistance. 

 

References

JIRA : HM-23368

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