Unable to register Veritas Alta View with the NetBackup primary server using NetBackup web UI - 'Credentials of Alta View are not Valid' error

Article: 100061097
Last Published: 2023-11-08
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

Unable to register Veritas Alta View with NetBackup primary server using the NetBackup web UI because of the invalid Veritas Alta View credentials error.   

Error Message

When you try to register Veritas Alta View with the primary server using the NetBackup web UI, the following error may be displayed in certain scenarios:

Credentials of Veritas Alta View are not Valid

Causes

Review the possible causes for the error:

Cause 1

The registration file that is downloaded using the Veritas Alta View UI may be expired.

Cause 2

Veritas Alta Connector is used to register the NetBackup primary server with Veritas Alta View.

Cause 3

The IT Analytics Data Collector is uninstalled and reinstalled on the NetBackup primary server.

Cause 4

The NetBackup primary server is already connected to an on-premise deployment of IT Analytics.

This error might occur even if the user provides the proper registration file with correct Alta View credentials. This is because the NetBackup services are not able to access the ItaStore directory due to incorrect user permissions of the directory. 

 

Solutions

Solution 1

Download a new registration file using the Veritas Alta View UI.

Solution for cause 2, cause 3, cause 4

Do the following:

1. Firstly, to determine the cause of the issue, check the permissions of the ItaStore directory on the NetBackup primary server.

The NetBackup user and the respective usergroup must have the read and write permissions on the ItaStore directory. 

Location of the ItaStore directory:

Linux -

/usr/openv/var/global/wmc/ItaStore

Windows - 

<NetBackup_Install_location>\NetBackup\var\global\wmc\ItaStore

2. If the required permissions are not present and the directory has only root or Administrator permissions, you must manually provide the read and write permissions to the NetBackup user and usergroup on the 'ItaStore' directory.

Linux: 

  1. Get the NetBackup user and usergroup names

    /usr/openv/netbackup/bin/admincmd/bpgetconfig WEBSVC_USER 
    Output: WEBSVC_USER = <UserName>

    /usr/openv/netbackup/bin/admincmd/bpgetconfig WEBSVC_GROUP 
    Output: WEBSVC_GROUP = <UserGroupName>

  2. Change the user and usergroup.
    chown <UserName>:<UserGroupName> /usr/openv/var/global/wmc/ItaStore

  3. Change the permissions for the owner user and usergroup.
    chmod 750 /usr/openv/var/global/wmc/ItaStore 

Run the following command to verify:

ls -l /usr/openv/var/global/wmc 
The permissions for the ItaStore directory should be:

drwxr-x---. .. <UserName><UserGroupName>

Command-line interface screenshot

Windows: 

  1. Open the command prompt (cmd) as Administrator and retrieve the NetBackup user name and usergroup name.
    "<NetBackup_Install_location>\NetBackup\bin\admincmd\bpgetconfig.exe" WEBSVC_USER 
    Output: WEBSVC_USER = <UserName>
    "<NetBackup_Install_location>\NetBackup\bin\admincmd\bpgetconfig.exe" WEBSVC_GROUP 
    Output: WEBSVC_GROUP = <UserGroupName>

  2. Retrieve the SID for the nbwebgrp user.
    wmic useraccount where "Name='nbwebsvc'" get SID 
    Save this SID as a variable:
    set SID=<SID_VALUE_FROM_PREVIOUS_COMMAND> 

  3. Use the following command to assign the required permissions:
    ICACLS "<NetBackup_Install_location>\NetBackup\var\global\wmc\ItaStore" /reset && ICACLS "<NetBackup_Install_location>\NetBackup\var\global\wmc\ItaStore" /setowner "*%SID%" && ICACLS "<NetBackup_Install_location>\NetBackup\var\global\wmc\ItaStore" /inheritance:r /grant "*%SID%":(OI)(CI)F /grant "*S-1-5-80-956008885-3418522649-1831038044-1853292631-2271478464":F /grant "*S-1-5-80-956008885-3418522649-1831038044-1853292631-2271478464":(CI)(IO)F /grant "*S-1-5-18":F /grant "*S-1-5-18":(OI)(CI)(IO)F /grant "*S-1-5-32-544":F /grant "*S-1-5-32-544":(OI)(CI)(IO)F /grant "*S-1-3-0":F /grant "*S-1-3-0":(OI)(CI)(IO)F

  4. Carry out the following steps to verify:
    • Open the C:\Program Files\VERITAS\NetBackup\var\global\wmc folder in file explorer.

    • Right-click and select Properties.

     

    • Go to the Security tab and click Advanced.

      

    • Owner should be the NetBackup user, it should be present in the Permission entries list, and it should have the Full control access.

   

 

References

JIRA : SC-56664

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