Problem
On NetBackup Appliance 5.3, if a NetBackup appliance has many storage LUNs, NetBackup fails to start when the appliance is restarted.
Error Message
When the command Support > Processes > NetBackup Show is run in the NetBackup Appliance Shell Menu, no NetBackup processes display. For example:
NB Processes
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spws 227324 1 0 Oct31 ? 00:07:35 /usr/openv/pdde/vpfs/bin/spws /usr/openv/pdde/vpfs/bin/.bin/spws start
MM Processes
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Shared Veritas Processes
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nbsvcusr 135045 1 0 Oct31 ? 00:00:26 /opt/VRTSpbx/bin/pbx_exchange
NetBackup Scale-out Relational Database Processes
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NetBackup IT Analytics Data Collector Processes
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Zookeeper Server is disabled
NetBackup IT Analytics WatchDog is stopped.
NetBackup IT Analytics WatchDog process appears to have been terminated unexpectedly.
NetBackup IT Analytics MetaDataCollector is stopped.
NetBackup IT Analytics EventDataCollector is stopped.
NetBackup IT Analytics DataCollector process is stopped.
NetBackup IT Analytics On-demand process is stopped.
NetBackup IT Analytics Message Relay Server process is stopped.
Cause
When many devices exist, the system recognizes them all when restarted.
However, some VxFS devices that are related to MSDP and AdvancedDisk are only recognized and mounted in the final stage of the restart.
NetBackup depends on the mounting of these related devices.
When NetBackup starts, these devices have not been mounted yet, which causes NetBackup to fail to start.
Solution
Use the following commands in the NetBackup Appliance Shell Menu to restart NetBackup:
Support> Processes> NetBackup Stop
Support> Processes> NetBackup Start