Problem
When upgrading from 9.1 or later releases, the NetBackup primary server upgrade on Windows appears to hang at the step: Granting full control to NetBackup services over NetBackup files.
Error Message
The upgrade window appears to hang on the step Granting full control to NetBackup services over NetBackup files.
Cause
There are a large number of files in the NetBackup installation directory other than <NetBackup_installation_directory>\NetBackup\logs and <NetBackup_installation_directory>\NetBackup\db\images directories. The process of granting permissions to the NetBackup services for the NetBackup installation directory is taking longer than expected.
Solution
During the upgrade, the nbserviceusercmd.exe process grants permissions to the NetBackup installation directory to the NetBackup services. Then nbfp.exe resets permissions on the NetBackup installation directory to the default secure permissions. If there are a large number of files in the NetBackup installation directory, the upgrade time may increase significantly.
Customers are advised not to create their own files under the NetBackup installation directory.
If the installer appears to hang on granting full control to NetBackup services over NetBackup files step, and the installation logs show that the installer is waiting for either the nbserviceusercmd.exe or the nbfp.exe command, allow the upgrade to continue. Do not stop the upgrade.
To determine the number of files in your NetBackup installation directory, use the command shown:
Using the Windows Powershell, run this command:
Get-ChildItem -Path "<NetBackup Installation Directory>" -recurse -Exclude "<NetBackup Installation Directory>\NetBackup\db\images\" | Measure-Object -Line
If the result of this command shows more than 300,000 files, contact support for assistance with the upgrade.