Malware scan jobs fails to mount backup image on scan host

Article: 100055980
Last Published: 2023-05-24
Ratings: 0 1
Product(s): NetBackup & Alta Data Protection

Problem

In the Netbackup WebUI, an error  "Failed to mount backup image" is reported when hovering over the malware scan job

The issue is seen when the Scan host is RHEL 8 and the Media Server is RHEL 7

 

Error Message

In ncfnbcs logs:

[RemoteCliHandler::getCommandStatus] Command stderr response : {"operation":"mount","errorcode":4,"errormessage":"Failed to mount image","errorstring":"mount.nfs: Connection timed out","mountdestpath":""}

[MalwareCmd::updateStatus] Failed to mount the backup image. (../helper/MalwareCmdMgmt.cpp:634)

[NbScanServiceClient::updateScanStatus] JSON Data to be posted :{"data": {"type": "scanStatusRequest", "id": 30, "attributes": {"status": "SCAN_FAILED", "scanResult": "NOT_SCANNED", "numberOfFilesImpacted": 0, "malwareToolSignature": "", "result": "Failed to mount the backup image."}}} (../helper/ScanServiceClient.cpp:339)

In nbmalwarescanner logs:

failed to mount image, error code: 8192, errorstring: mount.nfs: connection timed out

 

Cause

The issue occurs if mountd is not allowed on the scan host due to which it is unable to mount the image and hence not able to see the exported nfs 

 

Solution

1) To test if the scan host is able to mount, create a test nfs path to mount on the scan host.

2) Run -exportfs  to confirm it has been exported

3) Try to manually mount to confirm if the exported nfs can be seen on the scan host using below command

showmount -e <media_server_ip> 

OR

showmount -e <media_Server_hostname> 

4) If the output is hung and getting timed out with below error:

error: rpc: mount export: RPC: Timed out

Then confirm that mountd is added to the /etc/hosts.allow file on the scan host in the below format.

/etc/hosts.allow:

mountd : ALL : ALLOW

5) After updating the above file, it should now allow to use the malware scanning feature. 

 

 

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