NetBackup upgrade for Solaris clients to 10.1.x fail due to incorrect platform and/or missing packages
Problem
When attempting to upgrade Solaris 10 clients from NetBackup 8.1 to 10.1.1, the upgrade fails.
Error Message
The installation log from a Solaris client might show similar messages to the error below:
ERROR: Detected an attempt to install incorrect platform and/or
operating system and version client binaries on nbclient01
Some package(s) are missing:
119963-35
120753-17
Cause
The issue arises because the install/upgrade scripts are expecting the older package versions (e.g. 119963-35, 120753-17) as part of the minimum requirements. However, the OS has been updated to newer package versions (e.g. 119963-37, 120753-18). The updated package versions are not present, or checked, in the install/upgrade scripts, causing the error to be reported. This issue is resolved in NetBackup 10.2 or above.
To check for the specific Solaris package version, run OS level commands such as the examples below:
showrev -p | grep 119963Patch: 119963-37 Obsoletes: Requires: Incompatibles: Packages: SUNWlibC
showrev -p | grep 120753Patch: 120753-18 Obsoletes: Requires: Incompatibles: Packages: SUNWlibm, SUNWlibmsr
Note: To understand the pre-requisites for Solaris, please see the Related Articles below.
Solution
The best option is to upgrade the Solaris Clients to NetBackup 10.2 or above, where this issue is resolved.
Workaround
If the Solaris Clients cannot be upgraded to NetBackup version10.2, open a support case requesting the EEB 4160112 for updated Solaris NetBackup 10.1.1 installation/upgrade packages.