NetBackup DB health and connection status check.

Article: 100055395
Last Published: 2023-04-20
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

The NetBackup primary server upgrade fails during the db_ping_check pre-check.

 

Error Message

Scenario 1: The bpps command-line utility is unavailable:

not ok db_ping_check: bpps could not be run successfully.

This test checks if connections can be established with NetBackup databases.

Review the following article for more information:

https://www.veritas.com/support/en_US/article.100055395

The installer displays this message if the NetBackup CLI command bpps could not run or was not available.

 

Scenario 2: The NetBackup database service is unavailable:

For Linux:

not ok db_ping_check: NB_dbsrv daemon is not running. Please start the daemon and then retry.

This test checks if connections can be established with NetBackup databases.

Review the following article for more information:

https://www.veritas.com/support/en_US/article.100055395

For Windows:

not ok db_ping_check: NetBackup Relational Database Manager service is not running. Please start the service and then retry.

This test checks if connections can be established with NetBackup databases.

Review the following article for more information:

https://www.veritas.com/support/en_US/article.100055395

The installer displays this message if the NetBackup Sybase database service is unavailable for some reason. On Linux; this service is the nb_dbsrv daemon. On Windows this service is the NetBackup Relational Database Manager.

 

Scenario 3: One or more NetBackup databases when unavailable:.

not ok db_ping_check: The following NetBackup databases are not available:

<NBDB, NBAZDB, BMRDB>

Ensure that the databases are up by running the following command: nbdb_ping -dbn <database_name>

This test checks if connections can be established with NetBackup databases.

Review the following article for more information:

https://www.veritas.com/support/en_US/article.100055395

The installer displays this message if the connections to any of the NetBackup databases could not be established. It displays a comma-separated list of the databases where the connection could not be established. If BMR is installed, the installer checks the connection to BMRDB.

 

Scenario 4: The databases.conf file is unavailable:
not ok db_ping_check: No NetBackup databases found.

This test checks if connections can be established with NetBackup databases.

Review the following article for more information:

https://www.veritas.com/support/en_US/article.100055395

The installer displays this message if the databases.conf file is missing or could not be read.

 

Cause

This behavior is seen when there are problems detected with the database connectivity for any of the NetBackup databases while upgrading the NetBackup primary server from older versions to version 10.2 or later.

 

Solution

Scenario 1: Ensure that the binary bpps exists at the following location and is accessible and intact:

Linux: <install_dir>/netbackup/bin/bpps

Windows: <install_dir>\Veritas\NetBackup\bin\bpps.exe

Scenario 2:

The NetBackup Sybase database service/daemon needs to be running for this pre-check to establish connections with the NetBackup Sybase databases. These connections ensure that the databases are available before the upgrade starts. This check is important to avoid any problems with the other steps in the upgrade procedure.

 All the NetBackup services may have been stopped as part of the “Preinstall procedure for upgrading NetBackup”. If so, please follow these steps:

  1. Before starting the upgrade, start the database service using the following command:
    Linux: <install_dir>/netbackup/bin/nbdbms_start_stop start
    Windows: <install_dir>\Veritas\NetBackup\bin\bpup -e SQLANYs_VERITAS_NB
  2. For a clustered primary server, if the cluster is frozen (in case of Veritas Cluster Server) and the NetBackup resources are taken offline, run the above commands on the active node of the cluster to start the database service.
  3. Start the upgrade. Make sure all the critical pre-checks are successful including this one (named db_ping_check).

    Linux: When the installer asks the following question:
    Do you want to upgrade NetBackup and Media Manager? [y,n] (y)

    Windows: When the installer shows the summary page, Windows, do not proceed with the upgrade. Let the installer wait at this point.
     
  4. Stop the database service using the following command:
    Linux: <install_dir>/netbackup/bin/nbdbms_start_stop stop
    Windows: <install_dir>\Veritas\NetBackup\bin\bpdown -e SQLANYs_VERITAS_NB
  5. After the database service is stopped successfully, continue with the install. Click the Install button. Or enter 'y' at the following prompt: Do you want to upgrade NetBackup and Media Manager? [y,n] 

 

Scenario 3: For each database that is reported as not available, perform the following steps:

    1. Refer to the following article for troubleshooting:
      https://www.veritas.com/support/en_US/article.100024706.
    2. Ensure that any database-related operations were successful. For example, a password change.
    3. Check that there is successful connectivity to each database using the following command:
      Linux: <install_dir>/db/bin/nbdb_ping -dbn <database name>
      Windows: <install_dir>\Veritas\NetBackup\bin\nbdb_ping.exe -dbn <database name>
       
    4. Refer to the NetBackup Troubleshooting Guide:
      https://www.veritas.com/support/en_US/doc/15179611-127304775-0/index

Scenario 4:

  • Ensure that the databases.conf file is available and has entries for NBDB, NBAZDB and BMRDB (if BMR is installed).
  • For clustered setups, check that the share disk is mounted and available.

References

Etrack : ET-4110869

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