NetBackup SQL Intelligent Policy backup fails with Status Code 2 when SQL Server is using a non-standard port
Problem
The NetBackup SQL Intelligent Policy (SIP) backup of a SQL instance using a Non-Default SQL port, fails to connect to the SQL instance and fails with status 2.
Error Message
dbclient log on the SQL server shows below:
14:54:27.699 [15216.15944] <4> CDBIniParms::CDBIniParms: INF - NT User is SYSTEM
14:54:28.393 [15216.15944] <2> MssqlInstance::readSqlRegistry: DBG - Shared memory access is enabled (../MssqlDataObjs.cpp:2716)
14:55:37.139 [15216.15944] <2> logconnections: PROXY CONNECT FROM 10.18.3.10.58688 TO 10.17.77.232.1556 fd = 1196
14:55:37.139 [15216.15944] <2> logconnections: BPRD CONNECT FROM 127.0.0.1.65390 TO 127.0.0.1.58690 fd = 1196
14:55:37.151 [15216.15944] <4> CGlobalInformation::CreateDSN: INF - Failed to connect. Attempting operation with next installed ODBC Driver <SQL Server>
14:55:37.151 [15216.15944] <4> CGlobalInformation::CreateDSN: INF - Connecting to SERVER=SQLserver\instance
14:55:37.165 [15216.15944] <4> DBConnect: INF - Logging into SQL Server with DSN <NBMSSQL_15216_15944_3>, SQL userid <sa> handle <0xe4c71000>.
14:57:46.097 [15216.15944] <16> DBConnect: DBMS MSG - ODBC return code <-1>, SQL State <08001>, SQL Message <17><[Microsoft][ODBC SQL Server Driver][DBNETLIB]SQL Server does not exist or access denied.>.
Cause
This issue occurs because NetBackup is not able to connect to the SQL shared memory to get access to the SQL server instance.
Solution
Start the "SQL server browser service" on the SQL server
Then NetBackup was able to connect to the SQL instance using the shared memory and the SQL Intelligent Policy was successful.
Reference
SQL Server Browser service - SQL Server | Microsoft Learn