Problem
The Enterprise Vault (EV) Indexing service terminates due to Elasticsearch JVM timeout. This issue applies to EV 14.2 & later versions.
Error Message
Event ID: 41312 The Elasticsearch Indexing Engine could not complete all the required startup routines: Failed to start Elasticsearch JVM. Service will be stopped.
V-439-41312
Event ID: 41293 An unexpected error has occurred. |Error Summary: Indexing Service start up error |Error Details: Fatal error in Indexing Service child process EV Indexing Engine Elasticsearch.
V-439-41293
Cause
The Elasticssearch JVM takes more than (60 seconds) to start causing the EV indexing service to stop.
Solution
This issue can now be resolved by adding the below JVMStartUpTimeOutInSeconds app setting in the EVIndexingEngineElasticSearch.exe.config file, which is only available in EV 14.3.1 and later releases.
- Edit the EVIndexingEngineElasticsearch.exe.config file (<EVInstall Directory>\Enterprise Vault).
Add the
<appSettings>
value under the</configSections>
:
<appSettings>
<add key="JVMStartUpTimeOutInSeconds" value="240"/>
</appSettings>- Save the EVIndexingEngineElasticsearch.exe.config file.
- Start the EV Indexing service.
Note: The above setting only applies to EV version 14.3.1 or later.
EV 14.3.1 can be downloaded from here (Veritas Downloads).
Note: It may also be necessary to increase the Maximum child process startup time and Maximum indexing engine startup time to allow indexing to start properly.
- Open the Vault Administration Console (VAC).
- Expand Directory on Server_name > Site_Name > Enterprise Vault Servers
- Right-click on the server name and choose Properties
- Go to that Advanced tab and choose Indexing in List settings from:
- Modify Maximum child process startup time and Maximum indexing engine startup time to 5 and click OK.