Windows limitation to support encrypted folder Instant Access (IA) Mount and scan for malware

Article: 100053870
Last Published: 2022-09-14
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

There are two issues that can be experienced by users

1.    Instant access fails for encrypted folder on Windows clients

AND/OR

2.    The malware scan of a backup image fails with errors.

These issues are seen on Windows files and folders that have been encrypted through the Windows File Explorer options.

 

Error Message

Error seen for instant access for encrypted folder:

[INFO]: invalid id <ID> from backup read structure expected <1>
[ERROR]: failed to get fragment or readlen is zero
[ERROR] : fail to read backupread structure
[ERROR]: fail to GetExtentFromBKReadBlock

 

Error seen for malware scan:

Scan fails with following error in snip -

** Unable to check status of the mount due to an error in Instant Access  

Unable to importosTimage: (Could not import the ost image id (<IMAGE_ID>):
/<PATH>/bin/cata2map failed (255): **

 

Cause

The issue is with one of the tools:cata2map, used to create the Instant Access mount point. It does not decode the backup image properly.

cata2map creates the file system that is exported through Instant Access. In this case, cata2map does not calculate the correct offset and fails to create the filesystem. The malware scan uses Instant Access to create the export for scanning. So, the malware scan of a backup image also fails for this case.

This issue is with Instant Access only and is NOT a data corruption/data loss issue.

 

Solution

At this time, encrypted folders are not supported in the current release. 

There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. While this issue may be resolved in a future major revision of the software at a later time, it is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Veritas Sales representative or the Veritas Sales group to discuss these concerns.

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