Error: "No IMS is ready to receive API message !!" reported when attempting RG creation for VRP

Article: 100052733
Last Published: 2022-03-24
Ratings: 1 0
Product(s): Resiliency Platform

Problem

When attempting to configure/reconfigure a Resiliency Group (RG) for Veritas Resiliency Platform (VRP), the RG creation would fail at the "Configure Technology" phase at the sub-task of "Create the Veritas Replication Set on the ESX Cluster"

 

Error Message

No IMS is ready to receive the API message !!

 

Checking the cfs.log on the RM from /var/opt/VRTSitrp/logs location, it will report below entries for the problem IMS

DEBUG com.vrts.itrp.cfs.commandfacade.server.CmdFacadeService [cmdfacade.service.listenercontainer-1] Trying to fire api for local ims id : {xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx} and ims name : <FQDN_OF_IMS>

DEBUG com.vrts.itrp.cfs.commandfacade.server.CmdFacadeService [cmdfacade.service.listenercontainer-1]  Local endpoint with id: {xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}, name : <FQDN_OF_IMS>, not connected , will try others

 

Cause

The issue would likely occur due to either of the below reasons

a. The IMS is busy and hence not available to accept new connections.

b. The IMS is disconnected from the RM for the Resiliency domain.

 

Solution

To resolve the issue, below steps can be performed

1) From the VRP Console, verify the IMS status and it should show as Connected. 

If it shows as Disconnected, perform the "Reconnect IMS" operation from the VRP Console and wait for it to return back with the Connected state

2) If the issue occurs even when the IMS is already showing as Connected, then capture the name of the IMS listed in the cfs.log and perform a "Reconnect IMS" for that 

Retry the RG creation operation and it should now be able to complete. 

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