Problem
The green confirmation checkmark, indicating the end user has respond to the legal Hold email is not visible on the Legal Hold status page.
Error Message
<< Sever log >>WARN [litholds.server.SurveyRespMgrImpl] (Survey Response Monitor Thread:[]) Error Processing Record
com.teneo.esa.litholds.service.TeneoSSLHandshakeException: [#80085] Runtime exception: Exception in installing the server certificate required for HTTPS. : null
Caused by: java.io.IOException: DER length more than 4 bytes: 109
Cause
The cert KeyStore is in JKS format and must be converted to the BCFKS format for version 10 and above of the eDP product.
Solution
Change the cert KeyStore type to BCFKS
1. Download the Keystore Explorer tool.
2. Select 'Open an existing keystore' and navigate to the cert keystore.
Location: D:\CW\V100\scratch\temp
3. Change the cert KeyStore type from JKS to BCFKS and Save.
4. Restart the eDP services and verify the WARN is no longer in the server log.