仮想マシンのバックアップ時に VMware VSS Provider と Veritas VSS Provider の両方がインストールされていることが検出されました

Article: 100051648
Last Published: 2021-12-09
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Product(s): Backup Exec

問題

Backup Exec Agent for Windows Servers (AWS) がインストールされた VMware 仮想マシンをバックアップすると、ジョブログに例外が発生します。

 

エラー

V-79-8192-38331 - バックアップ時に、仮想マシン「仮想マシン名」に VMware VSS Provider と Backup Exec VSS Provider の両方がインストールされていることが検出されました。仮想マシンで使用できる VSS Provider は 1 つのみです。VMware VSS Provider をアンインストールする必要があります。

または

0xe0009574 - 仮想マシンのスナップショットを作成することができません。仮想マシンが存在しないか、ビジー状態のため、スナップショットを作成するために停止できない可能性があります。

 

原因

仮想マシンに AWS をインストールする際に、VMware Tools のサービスが検出されると、BEVSSProvider がインストールされます。 VMware Tools が 10.1 よりも低いバージョンであり、Backup Exec 16 Feature Pack 1 よりも低いバージョンである限り、AWS のインストールプロセス中に VMWare Tools VSS Provider を仮想マシンからアンインストールする必要があります。AWS がインストールされた後に VMware Tools が再インストールされた場合、または AWS のインストールで VMWare Tools VSS プロバイダーが完全に削除されなかった場合、2 つのプロバイダーがデッドロックし、この記事で提供されている警告 / 例外が発生します。

 

解決策

注1: Backup Exec 16 Feature Pack 1 (またはそれ以降) と VMware Tools 10.1 (またはそれ以降) の組み合わせでは、以下の 1 から 16 の手順は必要ありません。Backup Exec 16 Feature Pack 1 より前のバージョンを使用している場合は、最新版にアップグレードしてください。

注2: これらの手順の詳細は、AWS バージョン 16 と VMware Tools 9.10.5 を実行している Windows 2012 R2 の仮想マシン(VM)に基づいています。これらのコンポーネントのいずれかのバージョンが異なると、関連するステップの詳細に若干の違いが生じる可能性があります。

  1. VM 上で、スタートコントロールパネルプログラムプログラムと機能の順に開きます。
  2. VMware Tools を右クリックし、変更 を選択します。
  3. Next をクリックします。
  4. Modify ラジオボタンが選択されていることを確認し、Next をクリックします。
  5. Volume Shadow Service Support のドロップダウンから Entire feature will be unavailable を選択します。
  6. Next > Change > Finish の順で選びます。
  7. この時点では、VM の再起動は不要です。注意: OS やVmware Tools のバージョン、最近インストールしたアプリケーションによって、当該サーバーの VSS や Microsoft Installer (MSI) サブシステムの全体的な状態が変化している可能性があります。
  8. サービス管理を起動し、VMware Snapshot Provider がサービスとして表示されていないことを確認します。VMware Snapshot Provider が表示されている場合は、VMware社に連絡して VMware Snapshot Provider を手動で削除する方法を確認してください。
  9. 警告 / 例外メッセージを返していたバックアップジョブを実行します。
  10. バックアップジョブが警告 / 例外なしで終了した場合は、それ以上の手順は必要ありませんが、警告 / 例外のメッセージがまだ報告されている場合は、次の手順に進んでください。
  11. VM 内の REGEDIT を使用して、HKLM_System\CurrentControlSet\Services\BeVssProviderConflict が存在するか確認してください。
  12. このレジストリキーが存在する場合は、Administrator として notepad を起動します。
  13. notepad で C:\ProgramData\VMware\VMware Tools\manifest.txt を開きます。(注: この場所はデフォルトでは非表示になっています。)
  14. vcbprovider_2003.installed と vcbprovider.installed 2か所のエントリーを探します。
  15. 両方のエントリーが "FALSE" に設定されていることを確認してください。
  16. 警告 / 例外メッセージを返していたバックアップジョブを実行し、問題が解決されたかを確認します。

 

Backup Exec 16 FP1 および VMware Tools 10.1 (またはそれ以降) に関する情報

VMware Tools 10.1 を実行している VM に Backup Exec 16 Feature Pack 1 以降で提供される AWS をインストールしても、VMware VSS Provider は削除されず、代わりに以下のファイルが編集されます。

C:\ProgramData\VMware\VMware Tools\tools.conf

このファイルが編集 (または作成) され、以下のセクションが含まれるようになります。

[vmbackup]
 enableVSS = false

もし Backup Exec と VMware Tools 10.1 (またはそれ以降) のバージョンの組み合わせで警告/例外メッセージが表示された場合は、tools.conf の内容を確認し、必要に応じて管理者として編集する必要があります。

 

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