Replication, Duplication or Backup fails writing to NetBackup Cloud Catalyst Storage Unit with error 409
Problem
Replications, duplications or backups directed to Cloud Catalyst Storage Unit reports error 409. This has been seen with Hitachi Content Platform (HCP) implementations.
Error Message
For replications the following can be found:
Detailed Status:
Apr 16, 2021 10:54:52 AM - Critical bpdm (pid=85560) Storage Server Error: (Storage server: PureDisk:dtcnbu02) async_get_job_status: Replication started but failed to complete successfully: forward: importPDDE failed: unknown error. Look at the replication logs on the source storage server for more information. V-454-105
Apr 16, 2021 10:54:52 AM - Error bpdm (pid=85560) wait failed: error 150
Apr 16, 2021 10:54:52 AM - Error bpdm (pid=85560) <async> cancel failed: error 2060001: one or more invalid arguments
Apr 16, 2021 10:54:52 AM - Error bpdm (pid=85560) copy cancel failed: error 174
Apr 16, 2021 10:54:53 AM - Info dtcnbu02 (pid=85560) StorageServer=PureDisk:dtcnbu02; Report=PDDO Stats for (dtcnbu02): scanned: 4 KB, CR sent: 0 KB, CR sent over FC: 0 KB, dedup: 100.0%, cache disabled, where dedup space saving:0.0%, compression space saving:100.0%
Apr 16, 2021 10:54:53 AM - Error nbreplicate (pid=26338) ReplicationJob::Replicate: Replication failed for backup id baymax-01-bk.tucs.design.ti.com_1618583787: media write error (84)
Apr 16, 2021 10:54:52 AM - Error bpdm (pid=85560) wait failed: error 150
Apr 16, 2021 10:54:52 AM - Error bpdm (pid=85560) <async> cancel failed: error 2060001: one or more invalid arguments
Apr 16, 2021 10:54:52 AM - Error bpdm (pid=85560) copy cancel failed: error 174
Apr 16, 2021 10:54:53 AM - Info dtcnbu02 (pid=85560) StorageServer=PureDisk:dtcnbu02; Report=PDDO Stats for (dtcnbu02): scanned: 4 KB, CR sent: 0 KB, CR sent over FC: 0 KB, dedup: 100.0%, cache disabled, where dedup space saving:0.0%, compression space saving:100.0%
Apr 16, 2021 10:54:53 AM - Error nbreplicate (pid=26338) ReplicationJob::Replicate: Replication failed for backup id baymax-01-bk.tucs.design.ti.com_1618583787: media write error (84)
Replication logs:
April 16 11:39:31 ERR [139946472494848]: 0: syncRemoteToCloud: unexpected uploading status(409) after 1 query
April 16 11:39:31 ERR [139946472494848]: -1: forward: importPDDE failed: unknown error
April 16 11:39:31 ERR [139946472494848]: 4: ClientTask: job[24] failed(unknown error)
April 16 11:39:31 ERR [139946472494848]: -1: forward: importPDDE failed: unknown error
April 16 11:39:31 ERR [139946472494848]: 4: ClientTask: job[24] failed(unknown error)
For backup or duplications attempts you may find a message similar to this in the Detailed Status:
Oct 30, 2020 9:34:22 AM - Critical bpdm (pid=4922) sts_close_handle failed: 409 Not an OST error code
Oct 30, 2020 9:34:23 AM - Error bpdm (pid=4922) cannot write image to disk, media close failed with status 409
Oct 30, 2020 9:34:23 AM - Error bpdm (pid=4922) cannot write image to disk, media close failed with status 409
Cause
The particular Status Code means "OperationAborted: Object already exists", and indicates that the The versioning feature is not enabled in the Hitachi cloud storage settings for both the tenant and the bucket. This is a requisite as per Veritas documentation:
https://origin-download.veritas.com/resources/content/live/OSVC/100032000/100032807/en_US/nbu_80_hcl.html#cloud_storage_solutions-cloud_storage_-_vendor_compatibility-hitachi
Solution
Ensure Versioning is enabled on the namespace for the Hitachi Cloud Storage bucket settings.
Note: NetBackup 8.3 and later releases include support for MSDP Direct Cloud Tiering (also known as MSDP Cloud). This new technology is superior with improved performance, reliability, usability, and flexibility over the previous CloudCatalyst product. Customers are encouraged to move to MSDP Direct Cloud Tiering to take advantage of these improvements as well as future enhancements. See KB 100047875 for details.