A repair installation may be required when a Backup Exec patch/upgrade rolls back

Article: 100049824
Last Published: 2023-07-26
Ratings: 0 1
Product(s): Backup Exec

Problem

Error "The installation has failed and Backup Exec will roll back to existing version" is reported during Backup Exec patch/upgrade installation and repair installation of Backup Exec recommended.

 

Error Message

When installation fails, following pop-up error message recommending to repair Backup Exec will be displayed:

 

Cause

Due to errors encountered during the installation, installer rolls back the update to ensure that product is in usable state again. After roll back any of the following two scenarios can be observed. Solution of each scenario is described in solution section.

Scenario 1 - Virtfile Driver is uninstalled during rollback process. 

In some scenarios where the Backup Exec Virtfile driver cannot be rolled back, it is uninstalled by the installer to ensure the current version of the product remains usable with below limitations -

1. Backup Exec Lockdown feature is not activated.
2. Backups with Granular Recovery Technology (GRT) enabled will fail.
3. Restore which requires mounting of the GRT Backup Set will fail.

Scenario 2 - Virtfile Driver is not uninstalled during rollback process. 

If Virtfile.sys is present in windows C:\Windows\System32\drivers folder then a repair may not be needed as the driver rollback was successful. The patch install failure will need to be investigated before retrying the install again.

Solution

Solution for Scenario 1 - Virtfile Driver is uninstalled during rollback process. 

To continue using the current version of the Backup Exec product without above limitations follow the below steps to reinstall Virtfile driver.

1. Click OK so that the installation rollback starts.

2. When Installation rollback completes, deselect the reboot checkbox and click on OK.

3. Download the currently installed Backup Exec version ISO. Mount it to run a repair installation.

Note: Review the Backup Exec installation log. If the following install log error are observed additional steps are required before running a repair installation.

     A. Navigate to C:\Program Files\Veritas\Backup Exec\VirtFile folder.
     B. Right click on VirtFile.inf and select Install to reinstall VirtFile driver.

BKUPINSTXX.HTML
DIFXAPP: INFO: Unable to revert to a previous driver store for service 'VirtFile'.
DIFXAPP: INFO: Will attempt to uninstall the driver.
DIFXAPP: INFO: service 'VirtFile' was deleted.
DIFXAPP: INFO: RETURN: DriverPackageUninstallW (0x0)
DIFXAPP: ERROR: Rollback failed with error 0x2
DIFXAPP: RETURN: RollbackInstall() 2 (0x2)
CustomAction MsiRollbackInstall returned actual error code 1603 but will be translated to success due to continue marking


4. Reboot the Backup Exec server after repair installation completes.



Note: The above steps ensure that the current version of the Backup Exec product continues to function without any limitations listed above. To upgrade Backup Exec to next version (Scenario 2) of the product the primary reason for the rollback should be investigated and resolved.



Solution for Scenario 2 – Virtfile Driver is not uninstalled during rollback process. 

In this case repair may not be needed as the driver rollback was successful.

To install patch or upgrade the current version of Backup Exec product review the Installation Log located at C:\Program Data\Veritas\Backup Exec\Logs\BKUPINST*.htm

Resolve the error which caused installation failure and rollback. Retry the patch install again.

Review following documents to resolve the installation errors:

Upgrade checklist for Backup Exec

Troubleshooting installation issues in Backup Exec

Running the Veritas QuickAssist Help Tool

 

References

Etrack : 4031454

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