NetBackup client upgrade is failing with the error 'One or more NetBackup DLLs are currently in use'

Article: 100049680
Last Published: 2024-12-13
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

Netbackup client upgrade is failing with error 'One or more NetBackup DLLs are currently in use. Please address the processes responsible for this and retry installation.'

 

Error Message

Following pop-up message is seen during Netbackup client upgrade via graphical method:



Messages seen in install logs:

03-03-2021,12:39:15 : checking for DLLs in use at: C:\Program Files\VERITAS\NetBackup\bin\goodies
+ 03-03-2021,12:39:15 : found file in use: C:\Program Files\VERITAS\NetBackup\bin\goodies\libstsapi.dll
03-03-2021,12:39:16 : could not find processes responsible for file libstsapi.dll being held in use
+ 03-03-2021,12:39:16 : found file in use: C:\Program Files\VERITAS\NetBackup\bin\goodies\libVdb.dll
03-03-2021,12:39:16 : could not find processes responsible for file libVdb.dll being held in use

.
.
then..

+ 03-03-2021,12:39:24 : One or more NetBackup DLLs are currently in use. Please address the processes responsible for this and retry installation.
03-03-2021,13:12:41 : CustomAction Deferred_DuplicateDLLsCheck returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
+ 03-03-2021,13:12:42 : Action ended 13:12:42: InstallExecute. Return value 3.

 

Cause

Antivirus or anti-malware software is running on the client machine that might be preventing the uninstall step of the upgrade by locking the NetBackup dlls.

 

Solution

Disable any antivirus or anti-malware software while upgrading NetBackup binaries,  and/or add NetBackup processes and install paths to the exclude list of the antivirus or anti-malware applications.

More details about virus scanner exclusions are available here: General recommendations for virus scanner exclusions working with NetBackup

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