問題
Backup Exec で [システムログオンアカウント] のクレデンシャルを変更する手順について
原因
さまざまな理由により、Backup Exec [システムログオンアカウント] に関連付けられたクレデンシャルが、実際のドメインまたはシステムのクレデンシャルと非同期になることがあります。
これにより発生する問題としては、以下のようなものがあります。
- Backup Exec の [システムログオンアカウント] に関連付けられたユーザアカウントが古いパスワードであるため、ログオンの試行に失敗し、Active Directory 上でロックアウトされる可能性があります。
- 認証エラーにより、バックアップ/リストアジョブが失敗します。
解決策
Backup Exec 2012 以降、ログアカウントの管理は下記のように確認できます。
[管理コンソール] -> [構成と設定] -> [ログオンアカウント] -> [ログオンアカウントを管理する]
Backup Exec [システムログオンアカウント] を変更するには、保存されているパスワードが何か分かっている必要があります。
Backup Exec [システムログオンアカウント] のパスワードが不明な場合、このアカウントに変更を加えることはできません。
[システムログオンアカウント] は、以下の操作で削除し、再作成する必要があります。
[システムログオンアカウント] は [ログオンカウントを管理] の画面に表示されます。
[システムログオンアカウント] がない場合は、[ログオンカウントを管理] 画面の右側にある [システムアカウント] のボタンをクリックし、作成可能です。
このアカウントは Backup Exec サービスと通信する際に使用されます。
注意:Windows SYSTEM アカウントと Backup Exec の [システムログオンアカウント] は異なるものです。
Windows SYSTEM アカウントは、ユーザが指定可能な資格情報を持たない特別なユーザアカウントです。
Backup Exec の [システムログオンアカウント] は、インストール時にユーザ指定のログオンアカウントであり、Backup Exec が適切に動作するために必要なアカウントです。
[システムアカウント] というラベルの付いたボタンは、Windowsアカウントを参照していません。[システムアカウント] は Backup Exec の [システムログオンアカウント] の略です。
図1
[システムログオンアカウント] のパスワードが不明な場合は、次の操作を実施します。
1. [システムログオンアカウント] の「所有者」として表示されているアカウントで Backup Exec サーバーにログインします。
2. [ログオンアカウントの管理] 画面から、新しいアカウントを作成します。
3. [システムログオンアカウント] が [デフォルトアカウント] であるかを確認します。
[デフォルト] の列に [はい] が付いている場合、それはデフォルトアカウントを意味しています。
4. [システムログオンアカウント] を削除します。このアカウントは、「デフォルトアカウント」としてマークされている場合は削除できません。 上記の手順2. で作成した新しいアカウントを選択して、「デフォルトに設定」ボタンをクリックしてから [システムログオンアカウント] を削除します。
5. ポップアップ画面が表示されましたら、[置換] ボタンをクリックし、上記の手順2.で作成したアカウントをバックアップジョブに再割り当てします。
6. 右側の [システムアカウント] ボタンをクリックします。
7. [ドメイン名\ユーザー名] の形式でアカウント名を入力し、[パスワードの変更] ボタンからパスワードを設定します。
8. デフォルトのアカウントを作成するには [デフォルトアカウント] にチェックを入れ、[OK] ボタンをクリックします。
9. 上記の手順2.で作成したユーザーアカウントを削除し、ポップアップが表示されましたら、ジョブをシステムログオンアカウントに再度割り当てます。
多くの場合、Backup Exec サービスは [システムログオンアカウント] と同じアカウントを使用しているため、変更が必要になることがあります。 以下の手順を使用して、サービスの資格情報を変更します。
1. Backup Exec [管理コンソール] -> [構成と設定] -> [Backup Exec サービス] を起動し、[クレデンシャルの編集] を選択します。
2. [サービスアカウントのクレデンシャルを変更する] を選択します。
3. 更新されたアカウントを入力します。
4. Backup Exec サービスを再起動します。