Exchange GRT Browse of Exchange-Aware VMware policy backup fails with Database system error or file read failed.

Article: 100049037
Last Published: 2020-12-02
Ratings: 0 0
Product(s): NetBackup & Alta Data Protection

Problem

When the installation of Virtfile is not correct, Exchange GRT Browse of Exchange  VMWare policy fails.

Error Message

When browsing for an Exchange image you will see a "Database system error or file read failed." message

The error “Database System Error” is quite generic and there are multiple reasons for the failure, such as a timeout before bpdbm could locate the image, slow Disk STU, NFS mounting issues etc.

The technote talks about a specific issue with the virtfile driver causing this issue while browsing the backup images

The following will be seen in the NCFLBC debug log

03/11/2020 16:24:30.916 [Debug] NB 51216 ncfrai 158 PID:4664 TID:13256 File ID:351 [No context] 4 [[fsys\shared]       ] <from Producer::doIteration> Dll Name bedsxese.dll (../BEDSContext.cpp:159)
03/11/2020 16:24:30.916 [Debug] NB 51216 ncfrai 158 PID:4664 TID:13256 File ID:351 [No context] 4 [[fsys\shared]       ] <from Producer::doIteration> Dll Path  C:\Program Files\Veritas\NetBackup\bin (../BEDSContext.cpp:159)
03/11/2020 16:24:30.916 [Debug] NB 51216 ncfrai 158 PID:4664 TID:13256 File ID:351 [No context] 4 [[fsys\shared]       ] <from Producer::doIteration> Loading Dll  C:\Program Files\Veritas\NetBackup\bin\bedsxese.dll (../BEDSContext.cpp:159)
03/11/2020 16:24:30.916 [Debug] NB 51216 ncfrai 158 PID:4664 TID:13256 File ID:351 [No context] 4 [[fsys\jet]          ] <from Producer::doIteration> [LoadVirtApiDLL] maxAttempts = 3, interval = 1000 msec! (../BEDSContext.cpp:159)
03/11/2020 16:24:30.916 [Debug] NB 51216 ncfrai 158 PID:4664 TID:13256 File ID:351 [No context] 4 [[fsys\jet]          ] <from Producer::doIteration> VirtApi DLL WAS LOADED FROM VirtApi.dll.! (../BEDSContext.cpp:159)
03/11/2020 16:24:30.916 [Debug] NB 51216 ncfrai 158 PID:4664 TID:13256 File ID:351 [No context] 4 [[fsys\jet]          ] <from Producer::doIteration> [LoadVirtApiDLL] count = 0, goodLoad = false! (../BEDSContext.cpp:159)
03/11/2020 16:24:30.916 [Debug] NB 51216 ncfrai 158 PID:4664 TID:13256 File ID:351 [No context] 4 [[fsys\jet]          ] <from Producer::doIteration> Initial VirtApi DLL load check failed.  Will try again later. (../BEDSContext.cpp:159)

Cause

Installation of VirtFile is not correct or corrupted

Solution

Required VirtFile version :

<Install_Path>\Veritas\NetBackup\bin\VirtFile. 2.7.XXXX or higher.

Please follow the below steps to correct the VirtFile driver installation:

Go to <OS_Drive>:\Windows\System32\drivers and check version of VirtFile.sys.

  1.  If VirtFile.sys is not present

a.    Install it from <Install_Path>\Veritas\NetBackup\bin\VirtFile\VirtFile.inf

b.    On the command prompt, run “sc query VirtFile”.
c.    If the driver is not running, then run “sc start VirtFile” command.

2.    If versions of the VirtFile driver differ in Veritas\NetBackup\bin\ and Windows\System32 \drivers

a.   Stop NetBackkup services on the client machine using, <Install_Path>\Veritas\NetBackupbin\bpdown.exe
b.   On the command prompt, run “fltmc” to check if the VirtFile driver is loaded.
c.   If VirtFile is in the output list of fltmc, run “fltmc unload VirtFile” and ensure the driver is unloaded.
d.   Run "sc query VirtFile" to check if the driver is installed.
e.   Run "sc delete VirtFile".
f.    Remove "VirtFile.sys" from <OS_Drive>:\Windows\System32\drivers.
g.   Ensure below registry entries for VirtFile are cleaned up. Manually remove it if it exists.
 

i.    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DIFx\DriverStore\VirtFile_<GUID>\
ii.   HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\DIFxApp\Components\{<GUID>}  
iii.  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VirtFile

h.    Check if <OS_Drive>:\Windows\System32\DRVSTORE\VirtFile_***** exists, and if it does, remove it.
i.    Perform steps mentioned in point 1 for VirtFile driver installation.
j.    Start NBU services on the client machine using <Install_Path>\Veritas\NetBackup\bin\bpup.exe

3.    If the correct version is installed, reload VirtFile.sys by executing the following commands,
a.    Make NBU services down on client machine using,
<Install_Path>\Veritas\NetBackup\bin\bpdown.exe
b.    On the command prompt, run “fltmc” to check if the VirtFile driver is loaded.
c.    If VirtFile is in the output list of fltmc, run “fltmc unload VirtFile” and ensure the driver is unloaded.
d.    Run “fltmc load VirtFile”
e.    Start NBU services on the client machine using <Install_Path>\Veritas\NetBackup\bin\bpup.exe

This issue is for all NetBackup Versions after NetBackup 8.3

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