NetBackup Appliance HA upgrade to version 3.3.0.1 followed by switchover causes MSDP Cloud disk pool offline status

Article: 100048338
Last Published: 2020-10-05
Ratings: 0 0
Product(s): Appliances

Problem

After upgrading an appliance nodes in a high availability (HA) setup to version 3.3.0.1 and then performing a switchover, the MSDP Cloud disk pool is offline.

Error Message

Running the Manage > HighAvailability > Status command shows that the MSDP service status is "Partial" and that the MSDP Cloud disk pools are offline as follows:

Cause

The MSDP registry file is not getting updated during the 3.3.0.1 upgrade on the HA node, which prevents the MSDP Cloud service from starting automatically after the MSDP services have restarted. The result is the MSDP Cloud disk pool may be offline after NetBackup restarts, the system is rebooted, or after an HA switchover.

Solution

Perform the following tasks to resolve the issue:

  1. Log in as a NetBackup CLI user on the appliance where the MSDP service status is Partial.
  2. Run the following command to check if the MSDP Cloud service is enabled in the MSDP registry file:
    pdcfg --check=/msdp/data/dp1/pdvol/etc/pdregistry.cfg --section='Symantec/PureDisk/OpenCloudStorageDaemon

    If the output shows "Section"[Symantec/PureDisk/OpenCloudStorageDaemon]" does not exist in the configfile.", continue with the remaining steps. For any other output result, contact Veritas Support for assistance.
  3. Run the following command to enable the MSDP Cloud service in MSDP registry file:
    pdcfg --write=/msdp/data/dp1/pdvol/etc/pdregistry.cfg --section='Symantec/PureDisk/OpenCloudStorageDaemon' --option=loglevel --value='1'
  4. Run the following command to start the MSDP services:
    pdde start

Was this content helpful?