Preflight upgrade self-test fails when active jobs are falsely detected

Article: 100048337
Last Published: 2020-10-05
Ratings: 0 0
Product(s): Appliances

Problem

When you attempt to upgrade a NetBackup Appliance to versions 3.2 or 3.3.0.1, the preflight upgrade self-test reports that active jobs are in progress and pauses the upgrade.

Error Message

The preflight check shows the following message:

[Warning] The upgrade process has detected active jobs and is now paused. You must press 'q' to exit from this window and cancel the upgrade attempt. After you have stopped all active jobs and canceled all scheduled jobs, try the upgrade again.

Cause

If a client name includes the word "Active", the preflight upgrade self-test incorrectly interprets this occurrence as an active backup job.

To check for any backup jobs of clients that include the word “Active” in the client name, log in to the appliance as a NetBackup CLI user and run the following command:
/usr/openv/netbackup/bin/admincmd/bpdbjobs -report

The following output shows an example with a client name of “Bright-Active”:

JobID Type State Status Policy Schedule Client Dest Media Svr Active PID FATPipe
33315 Backup Done 0 VM_Application_one Daily Bright-Active symantec-nb 295578 No
33310 Snapshot Done 0 VM_Application_one - Bright-Active symantec-nb No
33306 Backup Done 0 Windows_Files_Level_Backup Daily BRIGHT-ACTIVE symantec-nb 285436 No
33297 Backup Done 0 VM_Application_one Daily Bright-Active symantec-nb 145919 No
33292 Snapshot Done 0 VM_Application_one - Bright-Active symantec-nb No
33290 Backup Done 0 Windows_Files_Level_Backup Daily BRIGHT-ACTIVE symantec-nb 144077 No
33289 Backup Done 0 VM_Application_one Daily Bright-Active symantec-nb 64806 No
33284 Snapshot Done 0 VM_Application_one - Bright-Active symantec-nb No
33278 Backup Done 0 Windows_Files_Level_Backup Daily BRIGHT-ACTIVE symantec-nb 51606 No

Solution

Use one of the following methods to resolve the issue:

Method 1:
Delete all jobs in the Activity Monitor for any clients that include “Active” in the client name, then try the upgrade again.

Method 2:
Modify the bp.conf file on the appliance as follows:

  1. Perform a backup on the appliance.
  2. Log in to the appliance as a NetBackup CLI user.
  3. Use a text editor or similar tool to open the bp.conf file, located in the following path:
    /usr/openv/netbackup/bp.conf
  4. Add the following lines to the bp.conf file which modifies the output for the bpdbjobs command:

    BPDBJOBS_COLDEFS = JOBID 5 false
    BPDBJOBS_COLDEFS = TYPE
    BPDBJOBS_COLDEFS = STATE
    BPDBJOBS_COLDEFS = STATUS 6
    BPDBJOBS_COLDEFS = POLICY
    BPDBJOBS_COLDEFS = SCHEDULE 8
    BPDBJOBS_COLDEFS = CLIENT
    BPDBJOBS_COLDEFS = DSTMEDIA_SERVER 14
    BPDBJOBS_COLDEFS = ACTPID 10
    BPDBJOBS_COLDEFS = FATPipe 7
  5. Log out of the NetBackup CLI user session and try the upgrade again.
  6. Once the upgrade has completed, remove the added lines from the bp.conf file.

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