How to collect logs from a VMware vCenter and ESX servers for use with Veritas Resiliency Platform

Article: 100048134
Last Published: 2020-08-04
Ratings: 9 8
Product(s): Resiliency Platform

Problem

In troubleshooting Veritas Resiliency Platform (VRP) it is sometimes needed to collect logs from the VMware vCenter and ESX servers

Cause

VRP performs many VMware related operations while performing Resiliency Group creation and while performing Resiliency Group migrations, takeovers and rehearsal operations.  As such, it is sometimes helpful to collect and review the VMware vCenter and ESX logs to see how these operations were performed or if there were failures while performing these operations.

Solution

Steps to collect ESXi logs. (Applicable for ESXi version 6.0 and above.)

Option-1: Steps to collect ESXi logs from vCenter UI.

1. Login to vCenter using Flash/HTML UI.

2. For vCenter version 6.0 to 6.5 from Flash UI right click on ESXi --> Export System Logs --> Click on the checkbox and select all sub options from these categories to collect ESXi logs for VAIO- Virtual Machines, Configuration, System, File System, CIM, Logs --> Follow the subsequent steps to collect ESXi logs.

3. For vCenter version 6.7 and above from HTML UI right click on ESXi --> Export System Logs --> Click on the checkbox and select all sub options from these categories to collect logs for VAIO- Virtual Machines, Configuration, System, File System, CIM, Logs --> Follow the subsequent steps to collect ESXi logs.

Option-2: Steps to collect ESXi logs from ESXi command line.

1. Login to ESXi using 'SSH'

2. Run 'vm-support' command from root shell to collect ESXi logs. (Note: In case you want to collect logs for specific VM's then use options available with 'vm-support' command and specify VM name to collect logs only for that VM.)

Note:
1. Whenever collecting logs for escalation, discuss with support/engineering and get details whether they want logs of vCenter or ESXi or Both (vCenter/ESXi)

2. In the future releases of ESXi, log collection options might be changing so according to that you need to check VMware documentation for collecting logs appropriately.

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Steps to collect Windows vCenter logs. (Applicable for vCenter version 6.0 and above.)

Option-1: Steps to collect vCenter logs from vCenter UI.

1. Login to vCenter using Flash/HTML UI.

2. For vCenter version 6.0 to 6.5 from Flash UI click on vCenter name --> Monitor --> System Logs --> Export System Logs --> Select checkbox of 'Include vCenter Server and vSphere Web Client logs' --> Follow the subsequent steps to collect logs.

3. For vCenter version 6.7 and above from HTML UI right click on vCenter --> Export System Logs --> Select checkbox of 'Include vCenter Server and vSphere UI Client logs' --> Follow the subsequent steps to collect logs.

Option-2: Steps to collect vCenter logs from vCenter command line.

1. Login to vCenter using 'Remote Desktop Connection'

2. Open Windows Power Shell --> Go to this location "C:\Program Files\VMware\vCenter Server\bin" --> Run '.\vc-support.bat' to collect vCenter logs. (Note: 'vc-support.bat' location may be different according to your vCenter installation location.)

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Steps to collect vCenter Appliance logs. (Applicable for vCenter version 6.0 and above.)

Option-1: Steps to collect vCenter logs from vCenter UI.

1. Login to vCenter using Flash/HTML UI.

2. For vCenter version 6.0 to 6.5 from Flash UI click on vCenter name --> Monitor --> System Logs --> Export System Logs --> Select checkbox of 'Include vCenter Server and vSphere Web Client logs' --> Follow the subsequent steps to collect logs.

3. For vCenter version 6.7 and above from HTML UI right click on vCenter --> Export System Logs --> Select checkbox of 'Include vCenter Server and vSphere UI Client logs' --> Follow the subsequent steps to collect logs.

Option-2: Steps to collect vCenter logs from vCenter command line.

1. Login to vCenter using SSH.

2. Run 'vc-support' command from root shell to collect vCenter logs.

Note:
1. Whenever collecting logs for escalation, discuss with support/engineering and get details whether they want logs of vCenter or ESXi or Both (vCenter/ESXi)

2. In the future releases of vCenter, log collection options might be changing so according to that you need to check VMware documentation for collecting logs appropriately.

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