Few NetBackup services won't start automatically after reboot on Windows 2012 R2

Article: 100047659
Last Published: 2023-01-18
Ratings: 1 0
Product(s): NetBackup & Alta Data Protection

Problem

After the upgrade from 7.7.3 to 8.1.2 , few NetBackup services won't start automatically after reboot. Though the startup type was set to Automatic.
Netbackup Agent Request Server ,Audit Manager ,EMM , Indexing Manager , NBRB , NBWMC were not starting automatically. ( Manual startup , works fine )

Error Message

Application Logs : 

" EMM interface initialization failed , status = 334 " ,  " failed to reset the device allocations for this host, status=3000000 "

System Logs :

 " The Netbackup Relational Database Manager Service Hung on starting ". Followed by other events for all the above stated services : "<Service-Name> depends on Netbackup Relational Database Manager service which failed to start because of the following error: After starting, the service hung in a start-pending state."

Cause

Less number of CPU cores.

Solution


1. Beginning with NetBackup 8.1, it is recommended that the master server host have 4 CPU cores. In this case there were only 2 CPU cores. 

This can cause performance issues and result in the service taking longer than usual to start and report ready to the Service Control Manager.

2. As a workaround  , Suggested to set the startup type of the services which were impacted to Automatic ( Delayed Start ) which will start the services automatically after reboot in such scenarios were the CPU cores are less. A service marked as Automatic (Delayed Start) will start shortly after all other services designated as Automatic have been started


 

 

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