Unable to perform GRT backups or to start remote agent after upgrading to Backup Exec 20.6 and above on Windows 2008 or 2008 R2 Operating System.
Problem
After upgrading to Backup Exec 20.6 and above on Windows 2008 or 2008 R2 Operating System.
Unable to perform GRT backups
- or -
Unable to start remote agent
Error Message
Possible Job Failures codes:
0xe000034c - Error: Unable to back up the selected resource using the specified options because the Backup Exec Active Directory Recovery Agent did not install completely.
0xe00002f7 - Cannot extract mailbox messages from the Exchange backup. Review the job log for more information.
Final error category: Resource Errors
V-79-57344-759 - Cannot complete the operation because the file VirtApi.dll is missing and the Agent for Microsoft Exchange Server did not install completely. Run the installation wizard, ensure that the agent is selected, and then retry the operation.
System Event Log:
Source: System Information
Event ID: 26
Description: Application popup: : \SystemRoot\system32\DRIVERS\VirtFile.sys failed to load
Cause
This issue may occur if Backup Exec is upgraded from prior versions to 20.6 or above on a Windows 2008 SP2 or Windows 2008 R2 operating system.
Common symptoms to identify the problem: :
- Backup Exec Lockdown setting cannot be enabled and results in error "Failed error : cannot update the disk storage lockdown setting. The Backup Exec lockdown service is not running ensure that the service is running before performing the action"
- Running the command "FLTMC" from command prompt indicates no "VIRTFILE" driver.present.
- GRT Backups of remote servers running Windows 2008 or Windows 2008R2 to tape may fail with the errors mention in the Error section of this article
- Hyper-V GRT backups to disk or tape fail.
- Running the command "Sc start Virtfile" results in the following output: "Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source."
Solution
Apply the following Windows updates to the affected server :
NOTE: This issue may also occur with fresh install of Backup Exec 20.x and 21.
Please note that Windows 2008 is not supported as Backup Exec Server with Backup Exec 21.
Veritas Tech Support article provides reference/s to third-party products and site/s merely as a convenience. The verification and validation of the information and the links to third-party web sites are not under the control of Veritas.
Veritas makes no representations about third-party web sites and the content. Using the non-Veritas information is at your own risk. Veritas is not responsible for the reliability of any data, opinions, advice, or statements. The inclusion of such information and links does not imply that Veritas endorses, recommends, or accepts any responsibility for the content.