Problem
NetBackup Web Management Service is not starting
Error Message
In a Service popup window:
Windows could not start the NetBackup Web Management Console on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to service-specific error code 6536.
In the Catalina Log:
21-Apr-2020 23:00:07.907 SEVERE [localhost-startStop-2] org.apache.catalina.core.StandardContext.listenerStart Exception sending context initialized event to listener instance of class [org.springframework.web.context.ContextLoaderListener]
org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'loginInfoAuthenticationService': Unsatisfied dependency expressed through field 'authenticator'; nested exception is org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'authenticator': Unsatisfied dependency expressed through field 'loginInfoAuthenticator'; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'loginInfoAuthenticator' defined in com.netbackup.config.CoreApplicationContext: Bean instantiation via factory method failed; nested exception is org.springframework.beans.BeanInstantiationException: Failed to instantiate [com.netbackup.webapp.gateway.service.security.LoginInfoAuthenticator]: Factory method 'loginInfoAuthenticator' threw exception; nested exception is java.lang.ExceptionInInitializerError
at org.springframework.beans.factory.annotation.AutowiredAnnotationBeanPostProcessor$AutowiredFieldElement.inject(AutowiredAnnotationBeanPostProcessor.java:588)
at org.springframework.beans.factory.annotation.InjectionMetadata.inject(InjectionMetadata.java:88)
at org.springframework.beans.factory.annotation.AutowiredAnnotationBeanPostProcessor.postProcessPropertyValues(AutowiredAnnotationBeanPostProcessor.java:366)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.populateBean(AbstractAut...
- Windows: install_path\NetBackup\wmc\webserver\logs\catalina.log
- UNIX/Linux: /usr/openv/wmc/webserver/logs/catalina.log
Cause
This issue can occur if a server was recently patched and may have caused the permission to reset.
Solution
- Reconfigure the wmc (Web Management Console) using the following commands.
- Windows:
install_path\NetBackup\wmc\bin\install\configureWmc
install_path\NetBackup\wmc\bin\install\configureCerts
install_path\NetBackup\wmc\bin\install\setupWmc - UNIX/Linux:
/usr/openv/wmc/bin/install/configureWmc
/usr/openv/wmc/bin/install/configureCerts
/usr/openv/wmc/bin/install/setupWmc
- Windows:
- Restart the NetBackup services.
- This should fix the wmc issue.
Note: For NetBackup versions 8.0 and 8.1.x, if you run the configureWmc command after the NetBackup 8.0, or 8.1.x HotFix from KB article 100044601 was installed, the security.war or netbackup.war are replaced with the original file. If so, please refer to the following KB article (100049294) for details and execute the steps described in the Solution section.